Page MenuHomePhabricator

HTML output of https://tools.wmflabs.org/admin/tools getting truncated
Closed, ResolvedPublic

Description

The HTML output of https://tools.wmflabs.org/admin/tools appears to be getting truncated. This is frustrating since I'd like to look up a tool that's past the "axel" entry.

$ curl -s "https://tools.wmflabs.org/admin/tools" | tail -20
            </h4>
    <h6 class="card-subtitle mb-2 text-muted">
      Tool: <a href="/admin/tool/axel">axel</a>
    </h6>
    <div class="card-text"></div>
          <dl class="row small">
                      <dt class="col-md-4">Maintainer</dt>
      <dd class="col-md-8 pl-0">
        <ul class="list-inline">
                                              <li class="list-inline-item">
            <a href="#!/maintainer/bd808" class="search">BryanDavis</a>
          </li>
                                </ul>
      </dd>
    </dl>
  </div>
</div><div class="card toolinfo" data-tool="badges">
  <div class="card-body">
    <h4 class="card-title">

Event Timeline

MZMcBride created this task.Jun 5 2019, 5:13 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 5 2019, 5:13 AM
bd808 added a subscriber: bd808.

I can reproduce on https://tools.wmflabs.org/admin/tools but not on https://tools.wmflabs.org/admin-beta/tools. Nothing in the error.log file indicating why the render is stopping in the middle of the list.

bd808 edited projects, added Tool-admin; removed Tools.Jun 6 2019, 5:24 AM

Mentioned in SAL (#wikimedia-cloud) [2019-06-06T22:37:44Z] <bd808> Updated to 2e083cc "Bump wikimedia/slimapp to dev-master" (T225046)

bd808 closed this task as Resolved.Jun 6 2019, 10:45 PM
bd808 claimed this task.

I'm not sure if the code update or the service restart fixed this, but it looks to be working now.

The running Kubernetes pod was a bit messed up: when I did webservice stop the Deployment object was deleted, but the ReplicaSet stayed alive. I had to force delete the ReplicaSet so that it would stop spawning new Pods before webservice --backend=kubernetes php7.2 start would work as expected. We don't seem to have an open bug for this behavior, but its not the first time I've seen it happen to a Kubernetes webservice. I'm not sure that making a task is very useful though because I think the fix is probably T214513: Deploy and migrate tools to a Kubernetes v1.15 or newer cluster which is being worked on currently.

Thank you for the quick fix!