Page MenuHomePhabricator

Missing i18n in FlaggedRevs
Closed, ResolvedPublic

Description

Error

Look at https://en.wikibooks.org/wiki/Special:PendingChanges or https://ca.wikinews.org/wiki/Plut%C3%B3_deixa_de_ser_planeta



Very likely caused by making FlaggedRevs use extension-wip.json

Details

Related Gerrit Patches:
mediawiki/extensions/FlaggedRevs : masterFix missing i18n due to extension-wip.json
mediawiki/extensions/FlaggedRevs : wmf/1.34.0-wmf.8Fix missing i18n due to extension-wip.json

Related Objects

Event Timeline

Ladsgroup triaged this task as Unbreak Now! priority.Jun 5 2019, 1:38 PM
Ladsgroup created this task.

Definitely a train blocker.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 5 2019, 1:39 PM
Reedy added a comment.Jun 5 2019, 1:42 PM

Do we need to add $wgMessageDirs and $wgExtensionMessagesFiles to FlaggedRevs.php so they can be picked up when pulled via extension-list?

Reedy added a comment.Jun 5 2019, 1:43 PM

Very likely caused by making FlaggedRevs use extension-wip.json

Is/Was it fine on .7?

Reedy added a comment.Jun 5 2019, 1:44 PM

Oh, ignore that. I couldn't see the revert in .7 of the wip patch

@Ladsgroup will this be fixed by train window tomorrow?

RazeSoldier added a subscriber: RazeSoldier.

These tags are not suitable for subtask of train.

@Ladsgroup will this be fixed by train window tomorrow?

I have no idea, I didn't touch those parts of the code. @Reedy definitely knows better but I think fixing them should not be that hard

Reedy added a comment.Jun 5 2019, 1:55 PM
$wgMessagesDirs['FlaggedRevs'] = __DIR__ . '/i18n/flaggedrevs';
$wgMessagesDirs['RevisionReview'] = __DIR__ . '/i18n/revisionreview';
$wgMessagesDirs['Stabilization'] = __DIR__ . '/i18n/stabilization';
$wgMessagesDirs['ReviewedVersions'] = __DIR__ . '/i18n/reviewedversions';
$wgMessagesDirs['UnreviewedPages'] = __DIR__ . '/i18n/unreviewedpages';
$wgMessagesDirs['PendingChanges'] = __DIR__ . '/i18n/pendingchanges';
$wgMessagesDirs['ProblemChanges'] = __DIR__ . '/i18n/problemchanges';
$wgMessagesDirs['ReviewedPages'] = __DIR__ . '/i18n/reviewedpages';
$wgMessagesDirs['StablePages'] = __DIR__ . '/i18n/stablepages';
$wgMessagesDirs['ConfiguredPages'] = __DIR__ . '/i18n/configuredpages';
$wgMessagesDirs['QualityOversight'] = __DIR__ . '/i18n/qualityoversight';
$wgMessagesDirs['ValidationStatistics'] = __DIR__ . '/i18n/validationstatistics';
$wgMessagesDirs['FlaggedRevsApi'] = __DIR__ . '/i18n/api';
$wgExtensionMessagesFiles['FlaggedRevsMagic'] = "$langDir/FlaggedRevs.i18n.magic.php";
$wgExtensionMessagesFiles['FlaggedRevsAliases'] = "$langDir/FlaggedRevs.alias.php";

Change 514475 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/FlaggedRevs@master] Fix missing i18n due to extension-wip.json

https://gerrit.wikimedia.org/r/514475

$wgMessagesDirs['FlaggedRevs'] = __DIR__ . '/i18n/flaggedrevs';
$wgMessagesDirs['RevisionReview'] = __DIR__ . '/i18n/revisionreview';
$wgMessagesDirs['Stabilization'] = __DIR__ . '/i18n/stabilization';
$wgMessagesDirs['ReviewedVersions'] = __DIR__ . '/i18n/reviewedversions';
$wgMessagesDirs['UnreviewedPages'] = __DIR__ . '/i18n/unreviewedpages';
$wgMessagesDirs['PendingChanges'] = __DIR__ . '/i18n/pendingchanges';
$wgMessagesDirs['ProblemChanges'] = __DIR__ . '/i18n/problemchanges';
$wgMessagesDirs['ReviewedPages'] = __DIR__ . '/i18n/reviewedpages';
$wgMessagesDirs['StablePages'] = __DIR__ . '/i18n/stablepages';
$wgMessagesDirs['ConfiguredPages'] = __DIR__ . '/i18n/configuredpages';
$wgMessagesDirs['QualityOversight'] = __DIR__ . '/i18n/qualityoversight';
$wgMessagesDirs['ValidationStatistics'] = __DIR__ . '/i18n/validationstatistics';
$wgMessagesDirs['FlaggedRevsApi'] = __DIR__ . '/i18n/api';
$wgExtensionMessagesFiles['FlaggedRevsMagic'] = "$langDir/FlaggedRevs.i18n.magic.php";
$wgExtensionMessagesFiles['FlaggedRevsAliases'] = "$langDir/FlaggedRevs.alias.php";

I can't unsee this. My eyes hurt now and I will have nightmares tonight...

Change 514493 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/FlaggedRevs@wmf/1.34.0-wmf.8] Fix missing i18n due to extension-wip.json

https://gerrit.wikimedia.org/r/514493

Change 514493 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@wmf/1.34.0-wmf.8] Fix missing i18n due to extension-wip.json

https://gerrit.wikimedia.org/r/514493

Reedy closed this task as Resolved.Jun 5 2019, 3:13 PM
Reedy removed a project: Patch-For-Review.

Scap is still running, but FR is now in ExtensionMessages-1.34.0-wmf.8.php (but wasn't before), so should have the desired effect

reedy@deploy1001:/srv/mediawiki-staging$ grep Flagged wmf-config/ExtensionMessages-1.34.0-wmf.8.php 
  'FlaggedRevsMagic' => "$IP/extensions/FlaggedRevs/frontend/language/FlaggedRevs.i18n.magic.php",
  'FlaggedRevsAliases' => "$IP/extensions/FlaggedRevs/frontend/language/FlaggedRevs.alias.php",
  'FlaggedRevs' => "$IP/extensions/FlaggedRevs/i18n/flaggedrevs",
  'RevisionReview' => "$IP/extensions/FlaggedRevs/i18n/revisionreview",
  'Stabilization' => "$IP/extensions/FlaggedRevs/i18n/stabilization",
  'ReviewedVersions' => "$IP/extensions/FlaggedRevs/i18n/reviewedversions",
  'UnreviewedPages' => "$IP/extensions/FlaggedRevs/i18n/unreviewedpages",
  'PendingChanges' => "$IP/extensions/FlaggedRevs/i18n/pendingchanges",
  'ProblemChanges' => "$IP/extensions/FlaggedRevs/i18n/problemchanges",
  'ReviewedPages' => "$IP/extensions/FlaggedRevs/i18n/reviewedpages",
  'StablePages' => "$IP/extensions/FlaggedRevs/i18n/stablepages",
  'ConfiguredPages' => "$IP/extensions/FlaggedRevs/i18n/configuredpages",
  'QualityOversight' => "$IP/extensions/FlaggedRevs/i18n/qualityoversight",
  'ValidationStatistics' => "$IP/extensions/FlaggedRevs/i18n/validationstatistics",
  'FlaggedRevsApi' => "$IP/extensions/FlaggedRevs/i18n/api",

Slightly relatedly... How this works for CirrusSearch without the same relevant code... https://github.com/wikimedia/mediawiki-extensions-CirrusSearch/blob/wmf/1.34.0-wmf.8/CirrusSearch.php - But whatever :P

Reedy added a comment.Jun 5 2019, 3:45 PM

Confirmed fixed

Change 514475 merged by jenkins-bot:
[mediawiki/extensions/FlaggedRevs@master] Fix missing i18n due to extension-wip.json

https://gerrit.wikimedia.org/r/514475