Page MenuHomePhabricator

Notification icon showed number, but "There are no notifications" after clicking on Wikidata
Open, HighPublic0 Story Points

Description

When I launched wikidata.org using my official account (User:NKohli (WMF)), I saw I had three pending notifications but on click, I see "There are no notifications" for both the Notices and Alerts tabs. No console errors. The API request seems to go through fine (200).

Not reproducible on other wmf.8 wikis.

Event Timeline

Niharika created this task.Jun 5 2019, 10:00 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJun 5 2019, 10:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Reedy triaged this task as High priority.Jun 5 2019, 10:46 PM
SBisson added a subscriber: SBisson.Jun 6 2019, 1:15 AM

@Niharika what do you see on Special:Notifications? Do you have Show notifications from other wikis checked in your wikidata or global preferences?

@Niharika what do you see on Special:Notifications? Do you have Show notifications from other wikis checked in your wikidata or global preferences?

I see "There are no notifications" on Special:Notifications. I do have that option checked in my wikidata prefs.

Reedy added a subscriber: Reedy.Jun 6 2019, 11:49 AM

I note I can also reproduce this, seemingly only on Wikidata does it show anything different.

Wikidata does show "older" notifications, but not the new ones I can see on other (.8 included) wikis

@Niharika looking at the DB you don't have any notifications on wikidata. Were you able to see those notifications from another wiki?

Reedy added a comment.Jun 7 2019, 8:21 PM

For me, this is how it's showing

@SBisson I didn't view them anywhere else, no. It doesn't show me any of my past (read) notifications on Wikidata either. This is what I see:

Addshore added a subscriber: Addshore.

Not sure if this is something for the Wikidata team, so removing from the campsite, but leaving on the wikidata board

Addshore moved this task from incoming to monitoring on the Wikidata board.Jun 24 2019, 10:39 PM

@Niharika according to @SBisson comment you did not have any notifications on wikidata.

@Niharika looking at the DB you don't have any notifications on wikidata. Were you able to see those notifications from another wiki?

Did you see the alerts/notices counter showing number, but the flyout shows "no notiifcations" when you clicked on the icon(s)? What do you see on your Special:Notifications page? Any notifications for other wikis?

@Niharika according to @SBisson comment you did not have any notifications on wikidata.

@Niharika looking at the DB you don't have any notifications on wikidata. Were you able to see those notifications from another wiki?

Did you see the alerts/notices counter showing number, but the flyout shows "no notiifcations" when you clicked on the icon(s)? What do you see on your Special:Notifications page? Any notifications for other wikis?

That is what happened. There was a number on the icon but clicking it showed No notifications. But now it does give me the notifications, although only the new ones and not any of my past notifications on Wikidata. The opposite of what Reedy said he's experiencing above. When I open the notification tab, I see a flash of the old notifications before they go away and only the new ones show. I can't replicate this on other wikis yet.

Aklapper renamed this task from Notifications appear to be broken on Wikidata to Notification icon showed number, but "There are no notifications" after clicking on Wikidata.Jun 25 2019, 5:16 PM
JTannerWMF added a subscriber: JTannerWMF.

We will keep an eye on this and look into it if anyone else runs into this same challenge.