Page MenuHomePhabricator

Minerva - Special:ContentTranslation displays TypeError:"options is null"
Closed, ResolvedPublic

Description

In enwiki (wmf.8) with MinerveNeue skin enabled, go to Special:ContentTranslation page - when page is loaded, the Console will display the following error

TypeError: "options is null"
    jQuery 3
    runScript https://en.wikipedia.org/w/load.php?lang=en&modules=startup&only=scripts&skin=minerva:13
    cssHandle https://en.wikipedia.org/w/load.php?lang=en&modules=startup&only=scripts&skin=minerva:14
    flushCssBuffer https://en.wikipedia.org/w/load.php?lang=en&modules=startup&only=scripts&skin=minerva:6

More details:

Exception in module-execute in module skins.minerva.scripts: load.php:67
TypeError: "options is null"
    jQuery 3
    
    createMainMenu
    
    <anonymous>
    
    <anonymous>
    runScript load.php:637
    cssHandle load.php:677
    flushCssBuffer load.php:269

Details

Related Gerrit Patches:
mediawiki/skins/MinervaNeue : masterGuard against undefined config variable

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 10 2019, 12:14 PM

Change 522550 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Guard against undefined config variable

https://gerrit.wikimedia.org/r/522550

Jdlrobson added a subscriber: Jdlrobson.

I get a different error:

load.php?lang=en&modules=startup&only=scripts&raw=1&skin=minerva:2 TypeError: Cannot set property 'activator' of null

when I visit https://en.wikipedia.beta.wmflabs.org/wiki/Special:ContentTranslation?useskin=minerva or https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:ContentTranslation

The problem is wgMinervaMenuData is being scrubbed from output. Looks like it's easily solved but will need someone from ContentTranslation team to review and confirm this patch fixes the problem:

Change 522550 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Guard against undefined config variable

https://gerrit.wikimedia.org/r/522550

Etonkovidova closed this task as Resolved.Aug 5 2019, 9:23 PM

No console errors for ContentTranslation with Minerva skin.

There seems to be some UI regression though:

(filed as T229886).