Page MenuHomePhabricator

2017WTE up/down cursoring skips multiple empty lines in Chrome
Closed, ResolvedPublic

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (599facff7)
VisualEditor/VisualEditor : masterRestore inline slugs in source mode for cursoring
VisualEditor/VisualEditor : masterRevert "Source mode performance optimizations"

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 11 2019, 5:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This only happens in Chrome. It works correctly in Firefox and Edge.

Jdforrester-WMF renamed this task from 2017WTE up/down cursoring skips multiple empty lines to 2017WTE up/down cursoring skips multiple empty lines in Chrome.Jun 18 2019, 4:23 PM

It also seems to be a recent regression in our code, I randomly picked a commit from February and this doesn't happen in that version. I'm bisecting now.

Caused by rGVEDc0799b060844: Source mode performance optimizations.

Looks like we actually need the slugs.

Change 518107 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] Revert "Source mode performance optimizations"

https://gerrit.wikimedia.org/r/518107

Change 518138 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Restore inline slugs in source mode for cursoring

https://gerrit.wikimedia.org/r/518138

Change 518107 abandoned by Esanders:
Revert "Source mode performance optimizations"

Reason:
Replaced with Ic1af43ba2f521246c5cc37126641883250a5a120

https://gerrit.wikimedia.org/r/518107

Change 518138 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Restore inline slugs in source mode for cursoring

https://gerrit.wikimedia.org/r/518138

Change 518174 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (599facff7)

https://gerrit.wikimedia.org/r/518174

Esanders triaged this task as High priority.Jun 21 2019, 10:33 AM
Esanders moved this task from Code review to QA on the VisualEditor (Current work) board.

Change 518174 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (599facff7)

https://gerrit.wikimedia.org/r/518174

matmarex moved this task from Inbox to Low Priority on the Editing QA board.Jun 26 2019, 8:02 PM
marcella edited projects, added Skipped QA; removed Editing QA.
ppelberg closed this task as Resolved.Sep 3 2019, 12:01 AM
ppelberg claimed this task.