Page MenuHomePhabricator

Homepage: recent questions links on mobile go to desktop site
Closed, ResolvedPublic

Description

Tapping on the links to view your question on your mentor's talk page leads to desktop version of the mentor's talk page.

  • Tapping on the link to view your question on your mentor's talk page, at the end of the "ask your mentor" flow, leads to desktop version of the mentor's talk page. Should go to mobile version of the page instead.
  • Tapping on one of the links in the "your recent questions" list in the mentorship module leads to desktop version of the mentor's talk page. Should go to mobile version of the page instead.

  • Tapping on the "View your mentor's other conversations" link in the mentorship module correctly leads to the mobile version of the mentor's talk page.

Tapping on the links to view your question on the Help desk leads to desktop version of the Help desk page.

  • Tapping on the link to view your question on the Help desk, at the end of the "ask the help desk" flow, leads to desktop version of the Help desk page. Should go to mobile version of the page instead.
  • Tapping on one of the links in the "your recent questions" list in the help module leads to desktop version of the Help desk page. Should go to mobile version of the page instead.
  • Tapping on the "View questions from other users" link in the mentorship module correctly leads to the mobile version of the Help desk page.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterUse relative URLs for stored recent questions
mediawiki/extensions/GrowthExperiments : masterRecent questions: use relative URLs

Event Timeline

SBisson created this task.Jun 12 2019, 7:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 12 2019, 7:00 PM
SBisson claimed this task.Jun 12 2019, 8:28 PM
SBisson edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
SBisson moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.
MMiller_WMF renamed this task from Recent questions link to desktop site to Homepage: recent questions links on mobile go to desktop site.Jun 12 2019, 10:10 PM
MMiller_WMF added subscribers: kostajh, Catrope, Etonkovidova and 4 others.

Change 516783 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Recent questions: use relative URLs

https://gerrit.wikimedia.org/r/516783

I'm not able to reproduce this on betalabs.

@Etonkovidova if you reported this initially. Can you clarify what you did?

Etonkovidova closed this task as Invalid.Jun 13 2019, 6:47 PM

Checked the links- all lead to mobile, not desktop.

Filed T225746: Homepage: mobile help module recent questions links to top of help desk

@SBisson This task was also reported by me. Same behavior and console output as T225661, plus:

[Report Only] Refused to load https://meta.m.wikimedia.beta.wmflabs.org/w/index.php?title=Special:BannerLoader&campaign=CN+browser+tests&banner=browser_test_b1&uselang=en&debug=false because it does not appear in the script-src directive of the Content Security Policy.

Change 516783 abandoned by Kosta Harlan:
Recent questions: use relative URLs

Reason:
Phab task is marked as invalid.

https://gerrit.wikimedia.org/r/516783

MMiller_WMF reopened this task as Open.Jun 14 2019, 6:32 PM

Re-opening because we are seeing this in a supported browser. @Cntlsn -- could you please attach a video of this happening? I am removing this from the MVP "Blocker" list and putting it in the "Desired" list because it is only in one browser.

Change 517638 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Use relative URLs for stored recent questions

https://gerrit.wikimedia.org/r/517638

Change 517638 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Use relative URLs for stored recent questions

https://gerrit.wikimedia.org/r/517638

Needs to be checked after deployment in testwiki.

Re-opening because we are seeing this in a supported browser. @Cntlsn -- could you please attach a video of this happening? I am removing this from the MVP "Blocker" list and putting it in the "Desired" list because it is only in one browser.

It'd be great to have more descriptions on how to reproduce the issue.

So far, I found the only one way to reproduce it - on mobile switch to Desktop view. Then, click on a username link or search for Special:Homepage and then recent questions links (and other links) will direct to Desktop view not mobile view.

Also, I saw the following behavior: redirecting from mobile Homepage to non-mobile Mentor talk page, but it was in the browser mobile emulator:
https://test.m.wikipedia.org/w/index.php?title=Special:Homepage&source=personaltoolslink&namespace=-1#/homepage/mentorship --->

https://test.wikipedia.org/wiki/User_talk:Sbisson_(WMF)#Question_from_Zilant17_(19:12,_30_May_2019)

@Cntlsn - if you can do a quick test for testwiki mobile (https://test.m.wikipedia.org/w/index.php?title=Special:Homepage&source=personaltoolslink&namespace=-1) or give me more details on how you observed the issue, it'd be helpful.

@Cntlsn and I tested this and he confirmed the fix on betalabs with his phone. New questions posted today correctly navigate to the mobile site while older questions (before the fix) redirect him to the desktop site.

@MMiller_WMF Do you think we need to try to go back and fix the old URLs? Note that this is probably rare; both the old and new URLs allow most people to correctly stay on the mobile site.

@SBisson -- we do not need to fix the old URLs. Is the fix for this issue the same as for T225661? If so, then both the task can live in Design Review so that @Cntlsn can verify that they work for him in Test Wiki when the code is there. These tasks do not block the mobile release.

It's different and not merged yet. That task is rightfully in "code review".

nray moved this task from Needs triage to Triaged on the Mobile board.Jul 1 2019, 5:59 PM
MMiller_WMF closed this task as Resolved.Jul 3 2019, 11:43 PM

This is working for me in Czech Wikipedia.