Page MenuHomePhabricator

After adding categories manually the warning to add categories is still shown
Closed, ResolvedPublic3 Story Points

Description

Steps to reproduce:

  • Try to import a file that has no categories in the file description
  • On the preview page you will see the warning that you should consider adding categories
  • Edit the file info and add categories manually
  • The warning will still be visible after you have submitted the change file info text

From feedback in T222873#5253969

Acceptance Criteria

  •  Remove the warning if there are categories in any cases, and add it whenever there are non again

Event Timeline

Lea_WMDE updated the task description. (Show Details)Jun 24 2019, 4:41 PM
Lea_WMDE set the point value for this task to 3.

Change 518948 had a related patch set uploaded (by Awight; owner: Awight):
[mediawiki/extensions/FileImporter@master] Only show categories encouragement when empty

https://gerrit.wikimedia.org/r/518948

For testing:

Add / remove categories by changing file info to see the information note appear and disappear.

Change 518948 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Only show categories encouragement when empty

https://gerrit.wikimedia.org/r/518948

Lea_WMDE closed this task as Resolved.Jun 25 2019, 5:52 PM
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2019-06-12 board.
Pikne added a subscriber: Pikne.Jul 6 2019, 7:43 PM

I wonder if would be possible to still show this warning if all present categories are hidden categories? It seems that this warning message is mostly unused now since all files need to include some good template (a license) that usually has a hidden tracking category on Commons.

I wonder if would be possible to still show this warning if all present categories are hidden categories? It seems that this warning message is mostly unused now since all files need to include some good template (a license) that usually has a hidden tracking category on Commons.

Hmmm true, I made this observation as well. - And I guess the idea would be having at least one non-hidden category then. - PM what do you think? @Lea_WMDE

I think this sounds like another ticket that should be estimated :) See T228992: Ask users to add a category, if there are no visible ones yet