Page MenuHomePhabricator

[Bug] Minerva's History Action "Compare selected revisions" button is missing padding [desktop]
Closed, ResolvedPublic3 Estimate Story PointsBUG REPORT

Description

Steps to reproduce

(Desktop Minerva)

Expected results

  • "Compare selected revisions" button is average sized and looks like what we show for the mobile site:

Actual results

  • "Compare selected revisions" button is tiny and looks like it doesn't belong.

Environments observed

  • Browser version: Chrome Version 75.0.3770.80
  • OS version: Mac OS 10.14.5
  • Device model: MacBook Pro
  • Device language: En

Check any additional observations

Dev notes

It's small because it's assuming the button is an mw-ui-button class which MF has because it sets the wgUseMediaWikiUIEverywhere config variable to true [1] (but minerva desktop does not do this).

This means it misses out on padding:

padding: 0.57142857em 0.9375em;

The fix is a one liner - to use the mediawiki ui mixin directly like so:

		.mw-history-compareselectedversions-button {
			.mw-ui-button();

[1] https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/6afd79dedaac229d4ff07148d7fcb4385dae96a0/includes/MobileFrontendHooks.php#L43

QA steps

Quick one.
Wait for the beta cluster to update
Then confirm the button on https://en.wikipedia.beta.wmflabs.org/wiki/Spain?action=history&useskin=minerva matches expected results (not the screenshot in actual results)

Details

Related Gerrit Patches:
mediawiki/skins/MinervaNeue : masterFix "Compare selected revisions" button padding

Event Timeline

nray created this task.Jun 14 2019, 12:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 14 2019, 12:25 AM
nray renamed this task from [Bug] Minerva History Action's "Compare selected revisions" button is itty bitty to [Bug] Minerva's History Action "Compare selected revisions" button is itty bitty.Jun 14 2019, 12:31 AM
ovasileva triaged this task as Medium priority.Jun 18 2019, 3:02 PM
ovasileva moved this task from Incoming to Upcoming on the Readers-Web-Backlog board.
MBinder_WMF changed the subtype of this task from "Task" to "Bug Report".Jun 19 2019, 4:23 PM
ovasileva set the point value for this task to 3.Jun 19 2019, 4:31 PM
ovasileva moved this task from Upcoming to Triaged but Future on the Readers-Web-Backlog board.
Jdlrobson added a subscriber: Jdlrobson.

I see this button is an input element. Is that why? Do we know why this is happening?

nray added a comment.EditedJul 16 2019, 1:50 AM

I see this button is an input element. Is that why? Do we know why this is happening?

I think it's small because it's missing the mw-ui-button class which MF has because it sets the wgUseMediaWikiUIEverywhere config variable to true [1] (but minerva desktop does not do this)

[1] https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/6afd79dedaac229d4ff07148d7fcb4385dae96a0/includes/MobileFrontendHooks.php#L43

nray updated the task description. (Show Details)Jul 16 2019, 1:51 AM
nray updated the task description. (Show Details)
nray updated the task description. (Show Details)
Jdlrobson renamed this task from [Bug] Minerva's History Action "Compare selected revisions" button is itty bitty to [Bug] Minerva's History Action "Compare selected revisions" button is missing padding [desktop].Jul 22 2019, 4:28 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson removed a project: EasyTimeline.

Change 526528 had a related patch set uploaded (by Ed; owner: Ed):
[mediawiki/skins/MinervaNeue@master] Fix "Compare selected revisions" button padding

https://gerrit.wikimedia.org/r/526528

Ed added a subscriber: Ed.Jul 30 2019, 9:03 PM
Jdlrobson updated the task description. (Show Details)Jul 30 2019, 9:05 PM

Thanks @Ed !!!

Change 526528 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Fix "Compare selected revisions" button padding

https://gerrit.wikimedia.org/r/526528

MBinder_WMF reassigned this task from Edtadros to nray.Aug 7 2019, 5:22 PM
MBinder_WMF added a subscriber: Edtadros.
nray added a comment.Aug 8 2019, 4:01 PM

Padding is restored

nray removed nray as the assignee of this task.Aug 8 2019, 4:01 PM
phuedx closed this task as Resolved.Aug 19 2019, 10:04 AM
phuedx claimed this task.
phuedx added a subscriber: phuedx.

Padding is restored

Confirmed on the BC as well as in production. Special thanks to @Ed!