Page MenuHomePhabricator

upload.wikimedia.org should not return HTTP 404 error in case of backend error
Closed, InvalidPublic

Description

$ curl -I https://upload.wikimedia.org/wikipedia/commons/thumb/8/8f/Isoetes_setaceum_Habitus_2010-10-03_FuentedeSanLorenzoSierraMadrona.jpg/250px-Isoetes_setaceum_Habitus_2010-10-03_FuentedeSanLorenzoSierraMadrona.jpg
HTTP/2 404 
date: Mon, 17 Jun 2019 12:01:18 GMT
content-type: text/html; charset=utf-8
content-length: 1836
server: Varnish
x-varnish: 158709953
x-cache: cp3038 int
x-cache-status: int-front

But the Image exists on commons:

$ curl -I https://upload.wikimedia.org/wikipedia/commons/1/1a/Poaceae_Habitus_2010-10-03_FuentedeSanLorenzoSierraMadrona.jpg
HTTP/2 200 
date: Mon, 17 Jun 2019 12:02:02 GMT
content-type: image/jpeg
content-length: 3663033
x-object-meta-sha1base36: 9gclsax9nls33aj9l94mcbk6r7ox6wv
accept-ranges: bytes
last-modified: Fri, 14 Jun 2019 14:31:38 GMT
etag: 7a0f64eaaebd0258ea8a0beb72e255f6

So we have here a kind of rendering/scalling issue in the backend. In that case, the HTTP error code should not be HTTP 404 IMO, it should be HTTP 50X.

It looks like a detail, but the problem is that currently there is no way to make the difference between a missing image and a thumbnail rendering problem.

Event Timeline

Kelson created this task.Jun 17 2019, 12:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 17 2019, 12:04 PM

The original and the thumbnail you are requesting are not the same, i.e. original is Poaceae_Habitus_2010-10-03_FuentedeSanLorenzoSierraMadrona.jpg and thumbnail is Isoetes_setaceum_Habitus_2010-10-03_FuentedeSanLorenzoSierraMadrona.jpg. Are there pages generated by mediawiki that generated the first thumbnail link you posted? I see the file has been archived/renamed over time.

Kelson added a comment.Jul 4 2019, 8:27 AM

@fgiunchedi You are perfectly right. This seems to be an invalid bug. In fact I made the error because "File:Poaceae Habitus 2010-10-03 FuentedeSanLorenzoSierraMadrona.jpg" has been redirected from "File:Isoetes setaceum Habitus 2010-10-03 FuentedeSanLorenzoSierraMadrona.jpg". This is probably a consequence of T226931

Kelson closed this task as Invalid.Jul 4 2019, 8:27 AM