Page MenuHomePhabricator

Barchart no longer works in Wikidata Query Service
Closed, ResolvedPublicBug

Description

Steps to Reproduce:

#defaultView:BarChart
SELECT ?year (COUNT(?work) AS ?count) {
  ?work wdt:P50 wd:Q20980928 ; wdt:P577 ?date .
  BIND(STR(YEAR(?date)) AS ?year)
}
GROUP BY ?year
ORDER BY ?year

https://w.wiki/54T (doesn't work)

https://query.wikidata.org/#%20%23defaultView%3ABarChart%0ASELECT%20%3Fyear%20%28COUNT%28%3Fwork%29%20AS%20%3Fcount%29%20%7B%0A%20%20%3Fwork%20wdt%3AP50%20wd%3AQ20980928%20%3B%20wdt%3AP577%20%3Fdate%20.%0A%20%20BIND%28STR%28YEAR%28%3Fdate%29%29%20AS%20%3Fyear%29%0A%7D%0AGROUP%20BY%20%3Fyear%0AORDER%20BY%20%3Fyear

Actual Results:

Table rendered and a (Danish) message "Ude af stand til at vise resultatet: Bar chart"

Expected Results:

Barchart shown

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptJun 18 2019, 12:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Fnielsen updated the task description. (Show Details)Jun 18 2019, 12:09 PM
Fnielsen updated the task description. (Show Details)

Quite a number of panels in Scholia has been affected by the change/bug, e.g., https://tools.wmflabs.org/scholia/author/Q20980928 "Number of publications per year", "Number of pages per year" and "Citations by year".

It does not seem to be able to handle STR and the first column now. But removing STR from BIND(STR(YEAR(?date)) AS ?year) does not help.

The query works fine, so I think the problem is in the UI. Maybe some broke due to Sesame upgrade. I'll take a look.

Change 517706 had a related patch set uploaded (by Smalyshev; owner: Smalyshev):
[wikidata/query/gui@master] Fix breakage in charts

https://gerrit.wikimedia.org/r/517706

Smalyshev triaged this task as High priority.Jun 18 2019, 6:21 PM

Change 517706 merged by jenkins-bot:
[wikidata/query/gui@master] Fix breakage in charts

https://gerrit.wikimedia.org/r/517706

Mentioned in SAL (#wikimedia-operations) [2019-06-18T20:19:42Z] <smalyshev@deploy1001> Started deploy [wdqs/wdqs@0a1c946]: deploy new GUI for T226017

Mentioned in SAL (#wikimedia-operations) [2019-06-18T20:49:45Z] <smalyshev@deploy1001> Finished deploy [wdqs/wdqs@0a1c946]: deploy new GUI for T226017 (duration: 30m 03s)

Smalyshev closed this task as Resolved.Jun 18 2019, 8:50 PM