Page MenuHomePhabricator

oathauth-ui-error-page-no-module need refining
Closed, ResolvedPublic

Description

If I swap module=top for module=lol, I get given (oathauth-ui-error-page-no-module) - No Two-factor authentication method is currently enabled.

This isn't true, there are some enabled; totp is enabled, but lol isn't

Event Timeline

Reedy created this task.Jun 18 2019, 10:01 PM

Is this issue still relevant? This message key is actually not used anymore, as error SpecialPage is gone now. I could not reproduce the issue

Reedy added a comment.Jul 31 2019, 1:17 PM

Is this issue still relevant? This message key is actually not used anymore, as error SpecialPage is gone now. I could not reproduce the issue

If this is the case, we should remove it from the en.json/qqq.json so translators are not translating it unnecessarily

Reedy added a comment.Jul 31 2019, 1:28 PM

Is this issue still relevant? This message key is actually not used anymore, as error SpecialPage is gone now. I could not reproduce the issue

If I visit Special:Manage_Two-factor_authentication&action=disable&module=foobar it just basically displays Special:Manage_Two-factor_authentication

So I will accept that it's been fixed as part of the refactoring etc

The message should definitely be removed though

Change 526667 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/OATHAuth@master] Remove orphaned oathauth-ui-error-page-no-module message

https://gerrit.wikimedia.org/r/526667

Change 526677 had a related patch set uploaded (by ItSpiderman; owner: ItSpiderman):
[mediawiki/extensions/OATHAuth@master] Remove unused message keys

https://gerrit.wikimedia.org/r/526677

Change 526667 merged by jenkins-bot:
[mediawiki/extensions/OATHAuth@master] Remove orphaned oathauth-ui-error-page-no-module message

https://gerrit.wikimedia.org/r/526667

Change 526677 abandoned by ItSpiderman:
Remove unused message keys

https://gerrit.wikimedia.org/r/526677

CCicalese_WMF closed this task as Resolved.Jul 31 2019, 4:41 PM
CCicalese_WMF claimed this task.