Page MenuHomePhabricator

Chemistry beaker icon should have open top
Closed, ResolvedPublic

Description

When drawing chemical apparatus, the top is left open unless the beaker has a lid[1][2][3]

Our current beaker icon will odd because of this, and in VE it is used for "Insert chemical formula" where those users will notice:

current

proposed

  1. https://commons.wikimedia.org/wiki/File:More_simple_chemistry_apparatus.gif
  2. https://www.goodscience.com.au/year-7-chemistry/scientific-diagrams/
  3. https://commons.wikimedia.org/wiki/File:Anaerobic_respiration_equipment.png

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 20 2019, 11:25 AM

Change 511007 had a related patch set uploaded (by Esanders; owner: Esanders):
[oojs/ui@master] Fix beaker icon to have an open top

https://gerrit.wikimedia.org/r/511007

Esanders added a subscriber: Volker_E.EditedJun 20 2019, 11:29 AM

@Volker_E:
Feedback from designers: “The previous version provides a more clear shape. When representing bottles that is the usual way to represent the contour. […] the change makes it more recognizable
https://thenounproject.com/search/?q=beaker”

Both open and closed icons are seen there (as are 2D and 3D).

When representing bottles ...

Maybe wine bottles, but it depends on the use case. At the moment the only user of this icon is "chemical formula" and in that context, the closed top is not the "usual way".

Esanders updated the task description. (Show Details)Jun 20 2019, 11:31 AM
Esanders updated the task description. (Show Details)
Volker_E moved this task from Backlog to Reviewing on the OOUI board.Jun 20 2019, 7:15 PM

Maybe wine bottles, but it depends on the use case. At the moment the only user of this icon is "chemical formula" and in that context, the closed top is not the "usual way".

As an icon the closed version helps to see it as a single shape. Chemical diagrams may have their norms, but I'm not convinced that we should replicate those when creating icons. Similarly, cartography has its norms like indicating the scale of a map, but that does not apply when creating an icon representing a map.

indicating the scale of a map

Some things will not translate or be visible at icon size. Unlike the map example, the closed top is clearly visible, stands out as wrong looking to the target audience, and is easily fixable

Volker_E closed this task as Declined.Jun 25 2019, 5:33 PM

Brought this up in today's Design update. Five designers voted for the beaker with closed top, none for the open one, with the arguments given in the task description.

This is an actively terrible decision, and undermines our entire purpose for educating the world and being a congruent voice in that experience. I emplore the designers to consider their audience better.

cmadeo added a subscriber: cmadeo.Jun 25 2019, 6:34 PM

I'd just like to interject here to say that the decisions that the designers came to today were based off of the icon style guide: https://design.wikimedia.org/style-guide/visual-style_icons.html. In particular the sections about Reduce to the essential form and utilizing Geometric shapes.

By opening up the beaker, we would be adhering to what is essentially a 'style guide' that is different from the one that has been defined by the WMF. Furthermore the open beaker illustrations shared in the initial task descriptions serve a different purpose than this icon. The icon's job is to visually represent 'Chemical formulas' whereas the open lid illustrations are elements from a diagram, which are intended to be used show how something works or to convey how an experiment can be reproduced.

For example, the OOUI icons are not intended to be combined together to create a diagram or a scene (https://commons.wikimedia.org/wiki/File:Anaerobic_respiration_equipment.png) just as I can imagine that the beaker diagram element used in that link is not intended to be used in isolation as an icon.

In particular the sections about Reduce to the essential form and utilizing Geometric shapes.

I don't think it's clear that an open beaker is not compatible with that. Closing the top barely changes the shape at all, one could even argue it makes it more complex.

For example, the OOUI icons are not intended to be combined together to create a diagram or a scene

No, but that doesn't mean we shouldn't use visual elements that are familiar to the intended audience. For example the 'Math' icon uses a valid Mathematical symbol, we don't take an existing symbol and "simplify" it to a point where it is no longer valid. See also T213199 where we fixed the music icon had been "simplified" to the point of looking visually glitched to anyone familiar with musical notation.

I understand why on pure aesthetics the closed top looks better to a designer, but I would suggest you consult with the intended audience here as their experience may be different from your own. I have spoken to a few friends who studied chemistry all of whom agreed (although admittedly all from the same background as myself).

cmadeo added a comment.Jul 1 2019, 1:50 PM

Due to the fact that there seems to be two very distinct sets of values and backgrounds going into this discussion, I'd suggest that we utilize UserTesting.com to get feedback from a more general group of potential users.

Due to the fact that there seems to be two very distinct sets of values and backgrounds going into this discussion, I'd suggest that we utilize UserTesting.com to get feedback from a more general group of potential users.

Or perhaps you could ask at https://en.wikipedia.org/wiki/Wikipedia:WikiProject_Chemistry?

cmadeo added a comment.EditedJul 1 2019, 2:44 PM

@Esanders, yes we could do that as well, but I think the question is also around recognition and overall coherence with the icon set for the general population of users who will see this icon while using Wikipedia. This icon set is meant to be understandable and appear cohesive to a broad set of users from a variety of backgrounds.

That being said, I think that I have explained why this icon was chosen by members of the design team, based on the heuristics I described in an earlier comment. Unless folks here would like to move forward with testing this icon I have nothing left to add to this discussion. I don't mean this with disrespect, or to shut down conversation, I simply have no other input to offer personally.


Edited since phrasing the first time around was more aggressive than I meant it to be, my apologies.

Note that an icon can be used in different contexts depending on how specific it is the implied meaning. In particular, the beaker icon has been used also to signal "experimental features" in the past:

Even if there are no experimental features active right now, we need to decide whether the beaker icon should cover also this meaning or it should be restricted only to represent "chemical formulas".

Even if there are no experimental features active right now, we need to decide whether the beaker icon should cover also this meaning or it should be restricted only to represent "chemical formulas".

In the long term I think it is better to avoid overloading icons with multiple meanings (although we are guilty of this ourselves in various places). Clearly at the moment this is not an issue, but for example if we wanted to add an experimental features tool to VisualEditor that could lead to confusion.

YBG added a subscriber: YBG.Aug 30 2019, 7:53 PM

A note here, the icon depicted here - whether open or closed - does NOT represent a beaker. See https://en.wikipedia.org/wiki/Beaker_(glassware).
The icon is depicting an Erlenmeyer flask. See https://en.wikipedia.org/wiki/Erlenmeyer_flask.
This distinction is clearly visible at https://commons.wikimedia.org/wiki/File:More_simple_chemistry_apparatus.gif, where the Erlenmeyer flask is referred to as a conical flask.

Now unless there is some difference in terminology in other English-speaking countries, I would posit that the very fact that the incorrect terminology is used in the phabricator item indicates either carelessness or a disconnect with the target audience.

Using a picture of a Erlenmeyer flask instead of a picture of a beaker is a good idea since it has a more distinctive shape. To make a beaker distinctive, one would have to over-emphasize the "beak" or pouring spout, which I don't think would work out.

The statement is made that "When drawing chemical apparatus, the top is left open unless the beaker has a lid". But the question is, why? Is it a matter of convention, esthetics, recognition, or usefulness? I believe that the reason for this observation is that the pictures shown are intended to be combined with other icons to create a large diagram containing multiple vessels. If this convention were not followed, a diagram such as the one in https://commons.wikimedia.org/wiki/File:Anaerobic_respiration_equipment.png would appear to show fluids flowing through walls.

But if I understand correctly, the purpose of this icon is to stand alone, not to be combined with other objects to create a complicated piece of chemical apparatus. That being the case, the need to not show fluids flowing through walls is immaterial; what is paramount is recognition and esthetics. On that basis, I believe the closed form is more recognizable and esthetically preferred.

I would gladly defer my opinion to others who are fluent in chemistry, but I would strongly encourage people to emphasize the opinions of the chemically fluent instead of the opinions of those who do not know the difference between a "beaker" and an 'Erlenmeyer flask".

DMacks added a subscriber: DMacks.Aug 31 2019, 4:44 AM

As far as terminology, "conical flask" is sometimes used as a synonym for "Erlenmeyer flask". But a flask (of which these are other shapes also) and a beaker are totally different profiles.

I think the closed-top is more visually understandable (helps distinguish the whole object). From the front, there actually is a glass rim all the way around: it doesn't look open unless you are looking down from slightly above. Looking at the photographs in the Commons cat, I always see a full outline of the glass object. And all of the clip-art of various glassware that comes with ChemDraw is full outline--there is an edge of the glass in front, even though the glass itself is clear and colorless. That would be analogous to "bellOutline" at the OOUI style guide, where a bell is open underneath but the icon is a solid line on the bottom.

A third option is a full solid (rather than only the outline whether or not it has a top That would be analogous to "funnel" at the OOUI style guide.

Thanks @YBG and @DMacks for your inputs, we've partly addressed this by renaming 'beaker' to 'labFlask'. Result is already in OOUI demos icon section visible.

Esanders changed the task status from Declined to Resolved.Sep 17 2019, 11:22 AM

Change 511007 abandoned by Esanders:
Fix beaker icon to have an open top

https://gerrit.wikimedia.org/r/511007