Page MenuHomePhabricator

Drop the `wikimedia_editor_tasks_entity_description_exists` table
Closed, ResolvedPublic

Description

The legacy wikimedia_editor_tasks_entity_description_exists table is no longer used and should be dropped in both the Beta Cluster (wikidatawiki) and production (wikidatawiki and also testwikidatawiki).

Dropped from:

Details

Related Gerrit Patches:
operations/puppet : productionfiltered_tables: Remove references to a table
mediawiki/extensions/WikimediaEditorTasks : masterDrop wikimedia_editor_tasks_entity_description_exists

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2019, 11:52 PM
Mholloway triaged this task as Medium priority.Jun 22 2019, 11:52 PM
Mholloway updated the task description. (Show Details)
Mholloway updated the task description. (Show Details)Jun 23 2019, 12:17 AM
Reedy added a subscriber: Reedy.Jun 23 2019, 12:29 AM

Noting, if a $updater->dropExtensionTable() call was added to MediaWiki\Extension\WikimediaEditorTasks\Hooks::onLoadExtensionSchemaUpdates to drop the table... This would've cleaned beta up by itself, and also cleaned up any developer installs too...

Change 518398 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/WikimediaEditorTasks@master] Drop wikimedia_editor_tasks_entity_description_exists

https://gerrit.wikimedia.org/r/518398

Reedy renamed this task from Drop the edit suggestions table to Drop the `wikimedia_editor_tasks_entity_description_exists` table.Jun 23 2019, 12:33 AM
Reedy added a project: Schema-change.
Reedy moved this task from Unsorted to Delete / Drop / Remove on the Schema-change board.
Reedy updated the task description. (Show Details)

Can this go anytime then?

Change 518398 merged by jenkins-bot:
[mediawiki/extensions/WikimediaEditorTasks@master] Drop wikimedia_editor_tasks_entity_description_exists

https://gerrit.wikimedia.org/r/518398

Reedy added a comment.Jun 23 2019, 8:29 PM

Confirmed cleaned up on beta by the patch being merged!

MariaDB [wikidatawiki]> show tables LIKE 'wikimedia_editor%';
+--------------------------------------------+
| Tables_in_wikidatawiki (wikimedia_editor%) |
+--------------------------------------------+
| wikimedia_editor_tasks_counts              |
| wikimedia_editor_tasks_keys                |
| wikimedia_editor_tasks_targets_passed      |
+--------------------------------------------+
3 rows in set (0.00 sec)

Mentioned in SAL (#wikimedia-operations) [2019-06-24T04:54:48Z] <marostegui> Rename table wikimedia_editor_tasks_entity_description_exists in db1092 T226326

Marostegui moved this task from Triage to In progress on the DBA board.

So for now I have renamed the table on db1092 and will leave it like that for a couple of days before dropping it for good, just to see if there are some unexpected issues:

root@db1092.eqiad.wmnet[wikidatawiki]> rename table wikimedia_editor_tasks_entity_description_exists to T226326_wikimedia_editor_tasks_entity_description_exists;
Query OK, 0 rows affected (0.01 sec)

root@db1092.eqiad.wmnet[wikidatawiki]> show create table T226326_wikimedia_editor_tasks_entity_description_exists\G
*************************** 1. row ***************************
       Table: T226326_wikimedia_editor_tasks_entity_description_exists
Create Table: CREATE TABLE `T226326_wikimedia_editor_tasks_entity_description_exists` (
  `wetede_entity_id` int(10) unsigned NOT NULL,
  `wetede_language` varbinary(32) NOT NULL,
  `wetede_description_exists` tinyint(4) NOT NULL DEFAULT '0',
  `wetede_rand` float NOT NULL,
  PRIMARY KEY (`wetede_entity_id`,`wetede_language`),
  KEY `wetede_rand` (`wetede_language`,`wetede_description_exists`,`wetede_rand`)
) ENGINE=InnoDB DEFAULT CHARSET=binary
1 row in set (0.00 sec)

Change 518455 had a related patch set uploaded (by Marostegui; owner: Marostegui):
[operations/puppet@production] filtered_tables: Remove references to a table

https://gerrit.wikimedia.org/r/518455

Mentioned in SAL (#wikimedia-operations) [2019-06-24T04:59:20Z] <marostegui> Rename table wikimedia_editor_tasks_entity_description_exists in db1123 (testwikidatawiki) T226326

Same has been done on testwikidatawiki on s3:

root@db1123.eqiad.wmnet[testwikidatawiki]> rename table wikimedia_editor_tasks_entity_description_exists to T226326_wikimedia_editor_tasks_entity_description_exists;
Query OK, 0 rows affected (0.01 sec)

root@db1123.eqiad.wmnet[testwikidatawiki]> show create table T226326_wikimedia_editor_tasks_entity_description_exists\G
*************************** 1. row ***************************
       Table: T226326_wikimedia_editor_tasks_entity_description_exists
Create Table: CREATE TABLE `T226326_wikimedia_editor_tasks_entity_description_exists` (
  `wetede_entity_id` int(10) unsigned NOT NULL,
  `wetede_language` varbinary(32) NOT NULL,
  `wetede_description_exists` tinyint(4) NOT NULL DEFAULT '0',
  `wetede_rand` float NOT NULL,
  PRIMARY KEY (`wetede_entity_id`,`wetede_language`),
  KEY `wetede_rand` (`wetede_language`,`wetede_description_exists`,`wetede_rand`)
) ENGINE=InnoDB DEFAULT CHARSET=binary
1 row in set (0.00 sec)

Change 518455 merged by Marostegui:
[operations/puppet@production] filtered_tables: Remove references to a table

https://gerrit.wikimedia.org/r/518455

Mentioned in SAL (#wikimedia-operations) [2019-06-26T05:46:50Z] <marostegui> wikimedia_editor_tasks_entity_description_exists from s3:testwikidatawiki T226326

Marostegui added a comment.EditedJun 26 2019, 5:46 AM

I have dropped this table from s3 (testwikidatawiki) which wasn't written since 27th March:

-rw-rw---- 1 mysql mysql 384K Mar 27 22:36 wikimedia_editor_tasks_entity_description_exists.ibd

I have though, taken a quick mysqldump just in case and left it at cumin1001. I will keep it there for a few days before deleting it:

-rw-r--r-- 1 root root 68K Jun 26 05:44 /home/marostegui/T226326/s3_wikimedia_editor_tasks_entity_description_exists.sql
Marostegui updated the task description. (Show Details)Jun 26 2019, 5:47 AM
Marostegui updated the task description. (Show Details)
Marostegui updated the task description. (Show Details)
Marostegui added a comment.EditedJun 26 2019, 5:56 AM

Deletion process for s8 (wikidata). The table is 6GB there.
Not written since 29th March:

-rw-rw---- 1 mysql mysql 6.3G Mar 29 05:58 wikimedia_editor_tasks_entity_description_exists.ibd

Temporary backup taken at cumin1001:

-rw-r--r-- 1 root root 1.7G Jun 26 05:54 /home/marostegui/T226326/s8_wikimedia_editor_tasks_entity_description_exists.sql

Host to drop the table from:

  • labsdb1012
  • labsdb1011
  • labsdb1010
  • labsdb1009
  • dbstore1005
  • db2100
  • db2094
  • db2086
  • db2085
  • db2083
  • db2082
  • db2081
  • db2080
  • db2079
  • db1126
  • db1124
  • db1116
  • db1109
  • db1104
  • db1101
  • db1099
  • db1092
  • db1087
  • db1071

Mentioned in SAL (#wikimedia-operations) [2019-06-26T05:57:56Z] <marostegui> wikimedia_editor_tasks_entity_description_exists from s8:testwikidatawiki T226326

Marostegui closed this task as Resolved.Jun 26 2019, 6:09 AM
Marostegui updated the task description. (Show Details)

All done