Page MenuHomePhabricator

Search icon on the Manage Translator Sandbox is not positioned properly on Timeless theme
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. Change the Theme to Timeless
  2. Go to Manage Translator Sandbox page

Actual Results:

The search icon near the Search requests textbox is not aligned properly.

Expected Results:

The search icon should be aligned properly as per the theme guidelines. Also need to confirm in the Vector theme.

Vector:

Timeless:

Details

Related Gerrit Patches:

Event Timeline

abi_ created this task.Jun 24 2019, 2:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 24 2019, 2:56 PM

@abi_: Are you sure that this a bug in MediaWiki-extensions-Translate and not in Timeless?

Isarra added a subscriber: Isarra.Jun 25 2019, 2:30 PM

Is likely caused by timeless' form styles, especially if the icon is some sort of form element as well. But why is there a randomly floating icon in any case?

abi_ added a comment.Jun 26 2019, 4:53 AM

@Aklapper: I think the markup needs to be updated because it doesn't look too good in vector either. The idea is to do some research and update the tag if necessary.

Change 519248 had a related patch set uploaded (by Abijeet Patro; owner: Abijeet Patro):
[mediawiki/extensions/Translate@master] Fix incorrectly aligned search icon on Timeless theme

https://gerrit.wikimedia.org/r/519248

abi_ added a comment.Jun 26 2019, 4:11 PM

Fixed by changing the CSS in the Translate extension,

Timeless:

Vector:

abi_ moved this task from Backlog to Under Review on the User-abi_ board.Jun 27 2019, 1:48 AM

Change 519248 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Fix incorrectly aligned search icon on Special:ManageTranslatorSandbox

https://gerrit.wikimedia.org/r/519248

abi_ moved this task from Under Review to QA on the User-abi_ board.Jun 28 2019, 4:41 PM
Amire80 added a subscriber: Amire80.Aug 8 2019, 7:29 AM

Tested with Timeless in English and Hebrew, looks good to me.

abi_ closed this task as Resolved.Aug 8 2019, 7:40 AM
abi_ claimed this task.

Thanks @Amire80.

Resolving this task since this is now tested on Translatewiki.net.