Timeline: Early dates (BC) break the timeline
Closed, DeclinedPublic

Description

Trying to display dates BC are breaking the timeline. This was not seen before, since the time type could not handle those days anyway, and now we see that there is a problem with them.


Version: unspecified
Severity: normal

bzimport set Reference to bz20650.
Denny created this task.Via LegacySep 15 2009, 9:53 AM
Aklapper added a comment.Via ConduitNov 26 2012, 9:59 PM

Denny: Any online wiki instance (URL) that this can be tested on?

Aklapper added a comment.Via ConduitJan 26 2013, 12:44 AM

Denny: Any online wiki instance (URL) that this can be tested on?

Toniher added a comment.Via ConduitMar 24 2013, 10:51 PM

I've commited a patch myself.

I've a private wiki for now, sorry:
https://gerrit.wikimedia.org/r/#/c/55522/

Toniher added a comment.Via ConduitMar 24 2013, 11:11 PM

The problem is that SMW BC dates are returned in a format like: '--356-08-29' and SIMILE expects something such as '-0356-08-29'

Aklapper closed this task as "Declined".Via WebThu, Apr 2, 2:42 PM

The Semantic MediaWiki developers requested in https://phabricator.wikimedia.org/T64114 to move their task tracking to https://github.com/SemanticMediaWiki and to close remaining tasks in Wikimedia Phabricator. If you still face the problem reported in this task in a supported version of SMW, please feel free to transfer your report to https://github.com/SemanticMediaWiki/SemanticResultFormats/issues . We are sorry for the inconvenience.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.