Page MenuHomePhabricator

Database query error in en.wikisource.org Special:Preferences Gadgets on save
Closed, InvalidPublic

Description

Steps to Reproduce:
Removed the tick from "Easy LST: Enable the easy section labeling syntax in the Page: namespace." and clicked on "Save"

Actual Results:

Received a query error on two attemps

The War with Mexico/Volume 2/Chapter 21/Notes
[XRPDAgpAAD4AAHZNMHUAAACM] 2019-06-26 19:10:10: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

[XRPDfwpAIC8AAGaD9owAAACT] 2019-06-26 19:12:15: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

Expected Results:

Save the changes

Event Timeline

Ineuw created this task.Jun 26 2019, 7:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2019, 7:21 PM
Ineuw added a comment.Jun 26 2019, 7:26 PM

It also affects the rendering of the GUI. With each scroll down the page, the "Save" button appears on the middle of the page/display.

Which of the Wikisource websites is this about? Please include links that allow someone else to reproduce: https://www.mediawiki.org/wiki/How_to_report_a_bug

Aklapper renamed this task from Database query error in Wikisource Preferences/Gadgets on save to Database query error in en.wikisource.org Special:Preferences Gadgets on save.Jun 26 2019, 7:34 PM
exception_url	       	/wiki/Special:Preferences

exception.file	       	/srv/mediawiki/php-1.34.0-wmf.11/includes/libs/rdbms/database/Database.php:1563

exception.message
A database query error has occurred. Did you forget to run your application's database schema updater after upgrading? 
Query: SELECT  user_id,user_name,user_real_name,user_email,user_touched,user_token,user_email_authenticated,user_email_token,user_email_token_expires,user_registration,user_editcount,user_actor.actor_id  FROM `user` JOIN `actor` `user_actor` ON ((user_actor.actor_user = user_id))   WHERE user_id = '114977'  LIMIT 1   FOR UPDATE
Function: User::loadFromDatabase
Error: 1205 Lock wait timeout exceeded; try restarting transaction (10.64.0.205)

exception.trace
#0 /srv/mediawiki/php-1.34.0-wmf.11/includes/libs/rdbms/database/Database.php(1531): Wikimedia\Rdbms\Database->getQueryExceptionAndLog(string, integer, string, string)
#1 /srv/mediawiki/php-1.34.0-wmf.11/includes/libs/rdbms/database/Database.php(1141): Wikimedia\Rdbms\Database->reportQueryError(string, integer, string, string, boolean)
#2 /srv/mediawiki/php-1.34.0-wmf.11/includes/libs/rdbms/database/Database.php(1759): Wikimedia\Rdbms\Database->query(string, string)
#3 /srv/mediawiki/php-1.34.0-wmf.11/includes/libs/rdbms/database/Database.php(1851): Wikimedia\Rdbms\Database->select(array, array, array, string, array, array)
#4 /srv/mediawiki/php-1.34.0-wmf.11/includes/user/User.php(1411): Wikimedia\Rdbms\Database->selectRow(array, array, array, string, array, array)
#5 /srv/mediawiki/php-1.34.0-wmf.11/includes/user/User.php(479): User->loadFromDatabase(integer)
#6 /srv/mediawiki/php-1.34.0-wmf.11/includes/user/User.php(5523): User->loadFromId(integer)
#7 /srv/mediawiki/php-1.34.0-wmf.11/includes/specials/SpecialPreferences.php(85): User->getInstanceForUpdate()
#8 /srv/mediawiki/php-1.34.0-wmf.11/includes/specialpage/SpecialPage.php(571): SpecialPreferences->execute(NULL)
#9 /srv/mediawiki/php-1.34.0-wmf.11/includes/specialpage/SpecialPageFactory.php(581): SpecialPage->run(NULL)
#10 /srv/mediawiki/php-1.34.0-wmf.11/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#11 /srv/mediawiki/php-1.34.0-wmf.11/includes/MediaWiki.php(884): MediaWiki->performRequest()
#12 /srv/mediawiki/php-1.34.0-wmf.11/includes/MediaWiki.php(515): MediaWiki->main()
#13 /srv/mediawiki/php-1.34.0-wmf.11/index.php(42): MediaWiki->run()
#14 /srv/mediawiki/w/index.php(3): include(string)
#15 {main}
JJMC89 triaged this task as Unbreak Now! priority.Jun 26 2019, 7:43 PM
JJMC89 added a subscriber: JJMC89.

Development blockers are UBN.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 26 2019, 7:43 PM

lock wait timeout? That seems a bit strange based on the query

I have successfully disabled and enabled Easy LST (and a few other gadgets) a few times with no issues. Probably just a temporary glitch during deployment caused by overloaded servers?

mmodell lowered the priority of this task from Unbreak Now! to Medium.Jun 26 2019, 8:04 PM

I have successfully disabled and enabled Easy LST (and a few other gadgets) a few times with no issues. Probably just a temporary glitch during deployment caused by overloaded servers?

I concur, that's what it looks like to me. Leaving the task open because I'm not 100% sure but until we have further confirmation then I don't think this is UBN!,

Xover added a subscriber: Xover.Jun 26 2019, 8:51 PM

I cannot reproduce this either.

It was resolved within a few minutes. If I can't close, then please close it. ty.

RhinosF1 added a subscriber: RhinosF1.EditedJun 26 2019, 11:05 PM

@Ineuw - Do you want this closing?

Ineuw added a comment.Jun 27 2019, 3:45 AM

Yes please.

Jdforrester-WMF closed this task as Invalid.Jun 27 2019, 3:45 AM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJun 27 2019, 3:45 AM
mmodell changed the subtype of this task from "Bug Report" to "Production Error".Aug 28 2019, 11:06 PM