Page MenuHomePhabricator

mwext-php72-phan-docker running composer under PHP 7.0
Closed, ResolvedPublic

Description

https://integration.wikimedia.org/ci/job/mwext-php72-phan-docker/916/console

19:22:44 + exec docker run --volume /srv/jenkins-workspace/workspace/mwext-php72-phan-docker/src:/mediawiki --volume /srv/jenkins-workspace/workspace/mwext-php72-phan-docker/src:/src --volume /srv/jenkins-workspace/workspace/mwext-php72-phan-docker/cache:/cache --volume /srv/jenkins-workspace/workspace/mwext-php72-phan-docker/log:/log --init --rm --label jenkins.job=mwext-php72-phan-docker --label jenkins.build=916 --env-file /dev/fd/63 docker-registry.wikimedia.org/releng/composer:0.1.9 --working-dir=/src/extensions/WebAuthn update --ansi --no-progress --prefer-dist --profile
19:22:44 ++ /usr/bin/env
19:22:44 ++ egrep -v '^(HOME|SHELL|PATH|LOGNAME|MAIL|HHVM_REPO_CENTRAL_PATH)='
19:22:45 [6.1MB/0.00s] Loading composer repositories with package information
19:22:45 [6.4MB/0.14s] Updating dependencies (including require-dev)
19:22:47 [181.3MB/2.64s] Your requirements could not be resolved to an installable set of packages.
19:22:47 [181.3MB/2.64s] 
19:22:47   Problem 1
19:22:47     - Installation request for web-auth/webauthn-lib v1.2.0 -> satisfiable by web-auth/webauthn-lib[v1.2.0].
19:22:47     - web-auth/webauthn-lib v1.2.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement.

Event Timeline

Reedy renamed this task from mwext-php72-phan-docker running some parts under PHP 7.0 to mwext-php72-phan-docker running composer under PHP 7.0.Jun 27 2019, 6:31 PM
Reedy created this task.
Reedy added a comment.Jun 27 2019, 6:40 PM

I thought https://gerrit.wikimedia.org/r/#/c/integration/config/+/519467/ would fix it... But still seems to be using the old version...

$ ~/.local/bin/jenkins-jobs  --conf etc/jenkins_jobs.ini update config/ 'php-composer-security-docker'
/home/reedy/jenkins-job-builder/jenkins_jobs/cache.py:60: YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated, as the default Loader is unsafe. Please read https://msg.pyyaml.org/load for full details.
  self.data = yaml.load(yfile)
INFO:jenkins_jobs.cli.subcommand.update:Updating jobs in ['config/'] (['php-composer-security-docker'])
INFO:jenkins_jobs.builder:Number of jobs generated:  1
INFO:jenkins_jobs.builder:Reconfiguring jenkins job php-composer-security-docker
INFO:jenkins_jobs.cli.subcommand.update:Number of jobs updated: 1
INFO:jenkins_jobs.builder:Number of views generated:  0
INFO:jenkins_jobs.cli.subcommand.update:Number of views updated: 0

That was fixed (once I re-pushed the phan jjb jobs), but for some reason it now can't find the gmp extension?

Jdforrester-WMF closed this task as Resolved.Jul 1 2019, 6:51 PM
Jdforrester-WMF claimed this task.
hashar reopened this task as Open.Jul 2 2019, 8:57 AM
hashar added a subscriber: hashar.

There is a problem with that change. The jjb macro docker-setup-mwext-for-phan is used by both php7.0 and php7.2 based jobs. So when editing it, it alters the jobs:

mwext-php70-phan-seccheck-docker
mwext-php70-phan-seccheck-docker-non-voting
mwskin-php70-phan-seccheck-docker
mwskin-php70-phan-seccheck-docker-non-voting
mwext-php72-phan-docker
mwext-php72-phan-seccheck-docker
mwext-php72-phan-seccheck-docker-non-voting
mwskin-php72-phan-docker
mwskin-php72-phan-seccheck-docker
mwskin-php72-phan-seccheck-docker-non-voting

Which also mean the php7.0 based jobs end up running composer update with PHP7.2.

There is a problem with that change. The jjb macro docker-setup-mwext-for-phan is used by both php7.0 and php7.2 based jobs. So when editing it, it alters the jobs:

mwext-php70-phan-seccheck-docker
mwext-php70-phan-seccheck-docker-non-voting
mwskin-php70-phan-seccheck-docker
mwskin-php70-phan-seccheck-docker-non-voting
mwext-php72-phan-docker
mwext-php72-phan-seccheck-docker
mwext-php72-phan-seccheck-docker-non-voting
mwskin-php72-phan-docker
mwskin-php72-phan-seccheck-docker
mwskin-php72-phan-seccheck-docker-non-voting

Which also mean the php7.0 based jobs end up running composer update with PHP7.2.

The problem is that we're still running php70 phan (seccheck) jobs, which will get fixed as soon as we can fix T218719.