Page MenuHomePhabricator

My sandbox has no save button
Closed, InvalidPublic

Description

I spent hours working on a draft of my first article in my sandbox, then discovered it has no save button at the bottom, where all of the help articles say there should be one. Now I am afraid to close the window or restart my computer and lose all of my work.

Event Timeline

EricaDS created this task.Jun 28 2019, 12:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2019, 12:00 AM
Aklapper changed the task status from Open to Stalled.EditedJun 28 2019, 8:33 AM

Hi @EricaDS, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report.
That can be a clear list of specific steps to reproduce the situation, including a link to a public website where the issue can be seen, the MediaWiki skin that you use, and browser information.

You can edit the task description by clicking Edit Task.

Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Hi,

First of all, you will get better help on Wiki, or if you need real time help on IRC: https://en.wikipedia.org/wiki/Wikipedia:IRC_help_disclaimer Phabricator is mostly (although not exclusively) for developer help and community members organization.

Second, you can always copy the text you wrote into a file in your computer. Select all in your edit box by pressing Control + a, copy it by pressing Control + c (Command key if on a mac) and paste it to, for example, to Notepad or TextEdit, by hitting Ctrl + V, then saving it to your computer, so you can safely close your browser and pc/laptop.

Third, please send us a screenshot of your screen to understand your problem, as well as more context (what is your username, what is the project and page you were edditing?). You can get a screenshot by hitting Print Scrn then pasting it to Paint, or Shift-Command-4 on a Mac. Common reasons include:

  • Not being logged in as your user
  • Editing the wrong page
  • Momentary server error
  • Note that in some wikis, "Save" is actually name "Publish changes" or similar

Thanks jcrespo.

I am actually already copying the article out of Word, but I have found that I have to add every citation one at a time, and that I have already spent a few hours on. When I tried copying and pasting back into Word, the Wikipedia citations were lost.

I do have a "publish page" option, but I thought pressing that means submitting my page for review, which I am not ready to do yet.

I have been keeping the page open so I won't lose my work, and when I just finally had a chance to go back and finish it, now the citation button is glitching, so I can't finish it. When I hit "Cite" instead of seeing the previous pop-up box where I can choose to generate a citation automatically, add one manually, or choose one already created, I now get [...] where the citation should go, and when I double click on that, I get what you see in my attached screenshot. I have tried adding a citation manually, as you can see here, then hit "Insert", but at that point it gets stuck in "thinking" mode and never comes out. I tried multiple times last week and again today, with the same results.

Thanks so much for your help,
Erica

So "publish..." is the button you are looking for- being on your sandbox it will be just a draft, not a main article namespace, but it will save it for later time.

Aklapper closed this task as Invalid.Jul 3 2019, 9:26 AM

"Save" is called "Publish Page" in this case (as your draft can be accessed by other people - it is not that only you can see your draft). :)

As there is no incorrect behavior in the software here, I am closing this task as invalid for the scope of Phabricator.
(It's a valid support request though, e.g. https://en.wikipedia.org/wiki/Wikipedia:Village_pump for the English Wikipedia etc)

So there is no way to save my draft without it being visible to others? Can they edit it once I hit "publish page"? I don't want it to be visible to others or to be reviewed for general publication until I finish adding the citations.

And there is a software error now, because it won't let me finish adding the citations.

So there is no way to save my draft without it being visible to others? Can they edit it once I hit "publish page"?

See the fifth bullet point on https://en.wikipedia.org/wiki/Help:Userspace_draft (if you refer to English Wikipedia).

And there is a software error now, because it won't let me finish adding the citations.

See https://www.mediawiki.org/wiki/How_to_report_a_bug - thanks!

Thank you Aklapper. I am finding Wikipedia very non-intuitive and hard to understand. Hopefully hitting "publish page" will fix the citation glitch and allow me to finish it...