Page MenuHomePhabricator

monobook skin "your alerts" click brings "your notices"
Closed, ResolvedPublic

Description

With the monobook skin, the display of "your alerts" and "your notices" is as expected, however, when you hover or click on "your alerts" it brings up the "your notices".

This issue only occurred after the version update this week.

In vector that issue does not exist

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2019, 11:26 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJun 29 2019, 1:57 AM

And done. Do we need to cherry pick or something for actual deployment (and see what else we broke rather immediately), or are folks happy with waiting for the usual trains this time?

And done. Do we need to cherry pick or something for actual deployment (and see what else we broke rather immediately), or are folks happy with waiting for the usual trains this time?

I can wait for the train. I have a couple of wikis not in monobook, so I can peruse elsewhere

We have a hack in on enwiki (MediaWiki:Monobook.css) so once the train rolls feel free to ping me to renormalize that.

Dvorapa added a subscriber: Dvorapa.Jul 1 2019, 7:41 AM

These changes improve things, but nonetheless, the personal menu is still broken in Monobook. To reproduce:

  1. Visit a wiki where the change is live already (e.g. beta.wmflabs), log in with a name that is not too short (since my name is quite short and shows the issues, you'll probably be able to verify them, too).
  2. Slowly decrease the width of the window and observe all the weirdness that happens:

At about 670px width, the link to the user page and the logo overlap, clicking on the link to the user page takes you to the main page instead.

At about 590px, the link to the user page starts vanishing to the left. The two Echo icons overlap the logo and are no longer clickable.

At 560px, the two Echo icons suddenly vanish.

At 550px, the responsive layout appears, where the two Echo icons overlap the user icon, and are unclickable.

matmarex added a subscriber: matmarex.EditedJul 12 2019, 7:28 PM

At about 670px width, the link to the user page and the logo overlap, clicking on the link to the user page takes you to the main page instead.
At about 590px, the link to the user page starts vanishing to the left. The two Echo icons overlap the logo and are no longer clickable.

I can reproduce this. It's a side-effect ofhttps://gerrit.wikimedia.org/r/c/mediawiki/skins/MonoBook/+/519587: when the personal menu is wider than the screen (browser window), previously it would be cut off on the right (and you could access the overflowing links by horizontal scrolling), but now it gets cut off on the left (and the overflowing links slide under the logo and then off the screen).

On a vanilla MediaWiki, this is probably never a problem because of the 550px mobile interface cutoff, but if you have a lot of extensions that add links to the personal bar (Echo, SandboxLink, BetaFeatures), it can get wider than 550px.

At 560px, the two Echo icons suddenly vanish.

I can't reproduce this. Never mind, I can. I couldn't see it because the mobile hack acts funny if you interact with the icons before triggering the mobile interface. I filed T227916.

At 550px, the responsive layout appears, where the two Echo icons overlap the user icon, and are unclickable.

I can't reproduce this.

I think the mobile interface behavior you might be talking about is intentional – there's a separate link to Notifications in the popup menu.

Change 522545 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/MonoBook@master] When the personal bar doesn't fit, make overflowing links usable

https://gerrit.wikimedia.org/r/522545

Change 522545 merged by jenkins-bot:
[mediawiki/skins/MonoBook@master] When the personal bar doesn't fit, make overflowing links usable

https://gerrit.wikimedia.org/r/522545

matmarex closed this task as Resolved.Jul 15 2019, 5:49 PM
matmarex assigned this task to Isarra.