Page MenuHomePhabricator

Grammatical error in Occitan "Last modified" string for June month (duplicated "de" in "junh de de 2020" due to local overrides)
Closed, InvalidPublic

Description

The attribution line on pages in the Occitan Wikipedia contains a grammatical error. It reads, for example, "Aquesta pagina es estada modificada pel darrièr còp lo 28 de junh de de 2019 a 17.53." instead of "Aquesta pagina es estada modificada pel darrièr còp lo 28 de junh de 2019 a 17.53."

Event Timeline

Nthep created this task.Jun 29 2019, 6:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2019, 6:25 PM
Reedy added a subscriber: Reedy.Jun 30 2019, 11:30 AM

I note the problem here seems to be "de de" between the month and the year instead of "de"

Took me a little while to notice/work it out

Aklapper renamed this task from Grammatical error in page attribution on Occitan Wikipedia to Grammatical error in "Last modified" string on Occitan Wikipedia when last edit was in the month June.Jun 30 2019, 12:01 PM

https://oc.wikipedia.org/wiki/MediaWiki:Lastmodifiedat looks okay to me. The $1 string is where the duplication of de de comes from.

$1 seems to use https://translatewiki.net/wiki/MediaWiki:June-gen/oc which is using a de preposition. MediaWiki is adding another one before the month name but I'm not sure where it comes from.

Stryn added a subscriber: Stryn.Jun 22 2020, 4:26 PM

The extra "de" is mostly confined to Wikipedia; it appears once on the Wiktionary landing page, but the Commons and the rest of Wiktionary are unaffected by the June bug.

It's possible it's in CLDR or the Wikimedia code somewhere; I just don't know where to pinpoint it, exactly. It's not in Mediawiki:Month-gen/oc, as a) all twelve have that 'de' and b) the Occitan wiki currently has a bug where the "de" before the month is *not* included (using 'long' by mistake). So something is written DE junh DE.

BrennodAloisi added a comment.EditedJun 28 2020, 1:47 AM

Nemo_bis's words: "It's either from CLDR or PHP which gets it from ICU which gets it from CLDR."

Aklapper renamed this task from Grammatical error in "Last modified" string on Occitan Wikipedia when last edit was in the month June to Grammatical error in Occitan "Last modified" string for June month (duplicated "de" in "junh de de 2020"; unclear where it's coming from).Jun 29 2020, 11:42 AM

Nemo_bis's words: "It's either from CLDR or PHP which gets it from ICU which gets it from CLDR."

If it’s ICU, can anyone replicate it locally with a newer libicu than wikimedia uses?

Reedy added a comment.Jun 29 2020, 1:01 PM

Except, if I try ?uselang=oc on enwiki

Aquesta pagina es estada modificada pel darrièr còp lo 10 de junh de 2020 a 21.46.

So it's feels like a local wiki override. If it was CLDR/ICU/PHP/MW etc, it (sh|w)ould appear on enwiki with ?uselang=oc

And if we look at local message customisations

https://oc.wikipedia.org/wiki/Especial:Messatge_sist%C3%A8ma?prefix=&filter=modified&lang=oc&limit=5000

July has no trailing "de", june and jun do

https://oc.wikipedia.org/w/index.php?title=MediaWiki:Jun&action=history
https://oc.wikipedia.org/w/index.php?title=MediaWiki:June&action=history

And have been that way for over 10 years

I'm guessing something changed in MW to fix this mistake, and the local overrides weren't changed. If they're wrong, just delete them so they use the versions in MediaWiki itself

There's quite a lot of overrides on the wiki... I wonder why. And why for date/month parts?

Aklapper renamed this task from Grammatical error in Occitan "Last modified" string for June month (duplicated "de" in "junh de de 2020"; unclear where it's coming from) to Grammatical error in Occitan "Last modified" string for June month (duplicated "de" in "junh de de 2020" due to local overrides).Jun 29 2020, 3:07 PM
Aklapper closed this task as Invalid.Jun 29 2020, 3:11 PM

Thanks Reedy for finding the root cause! I'm closing this task as this is on-wiki content that needs to be fixed by the Occitan community, and we don't track on-wiki content issues in Phabricator. Please bring this up on https://oc.wikipedia.org/wiki/Wikipèdia:La_tavèrna