Page MenuHomePhabricator

Opening a file from commons on the web within the app in the image cation translation menu fails due to extra "file" prefix
Closed, ResolvedPublicBug

Description

Steps to reproduce

  1. pick an image on an article
  2. click it
  3. Click the little pencil icon to edit the image caption
  4. scroll up the card with the image info until you get to the end where it says file page on commons
  5. click it
  6. get no page due to an extra file prefix

Expected results

Get to the file page

Actual results

you get a nice no file with this name exists

Environments observed

App version: 2.7.50282-alpha-2019-07-01
Android OS versions: 9
Device model: pixel 2
Device language:Hebrew

Event Timeline

Matanya created this task.Jul 1 2019, 9:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2019, 9:16 PM

Hi, @Matanya

This is hard to reproduce but my guess is that the file namespace is not "File:" but in another language.

It would be helpful if you can provide any information about the image.

The Hebrew word for the file namespace is קובץ

ABorbaWMF added a subscriber: ABorbaWMF.

Working for me on 2.7.50282-alpha-2019-07-08 in Hebrew and English and Spanish

Dbrant closed this task as Resolved.Jul 11 2019, 3:51 PM