Page MenuHomePhabricator

[Bug] Proton fails in CI and locally for node 6.x
Closed, ResolvedPublic

Description

Proton is failing for code already in production (current master) locally and for CI jobs.

Production is not affected.

Steps to Reproduce

Get latest Proton code and run npm test for it or submit any patch that doesn't change any code, like 516710.

Expected Results

Tests don't fail.

Actual Results

Tests fail with some 404 status and the following message:

HTTPError: request.uri.includes is not a function

Environments Observed

  • Local and CI

Event Timeline

MSantos created this task.Jul 2 2019, 6:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 2 2019, 6:12 PM

There might be a breaking change upstream in one of the items npm pulls in? Because you're not on node10 you don't get the package-lock goodness…

WDoranWMF triaged this task as Normal priority.Jul 2 2019, 6:41 PM

OK, the last successful build of chromium-render-npm-browser-node-6-docker was on 29 April, #238, for change 504891 which was WIP. I just manually re-triggered this run as #243 and it failed with the same issue. It looks pretty likely that this is an upstream breakage.

Thanks for investigating, @Jdforrester-WMF. Looks like it's really time for T217114: Migrate Proton to nodejs 10 to happen.

That'd be lovely! One fewer node6 image for me to have to manage. ;-)

Change 520307 had a related patch set uploaded (by MSantos; owner: MSantos):
[mediawiki/services/chromium-render@master] Fix html2pdf route

https://gerrit.wikimedia.org/r/520307

Change 520307 merged by jenkins-bot:
[mediawiki/services/chromium-render@master] Fix html2pdf route

https://gerrit.wikimedia.org/r/520307

MSantos claimed this task.Jul 9 2019, 3:34 PM

Mentioned in SAL (#wikimedia-operations) [2019-07-31T19:59:53Z] <mbsantos@deploy1001> Started deploy [proton/deploy@ed6ebd8]: Update chromium-renderer to 529c493 (T227124)

Mentioned in SAL (#wikimedia-operations) [2019-07-31T20:01:37Z] <mbsantos@deploy1001> Finished deploy [proton/deploy@ed6ebd8]: Update chromium-renderer to 529c493 (T227124) (duration: 01m 43s)

MSantos closed this task as Resolved.Wed, Jul 31, 8:02 PM