Page MenuHomePhabricator

Please rebuild Jessie base image due to rsyslog upgrade breakage
Open, Needs TriagePublic

Description

The jessie image on WMCS comes with rsyslog 8.38.0-1~bpo8+wmf1, in jessie-wikimedia there is a newer version 8.1901.0-1~bpo8+wmf1 which is broken and can not upgrade the package (T222166). That means every time we build a Jessie image, puppet / apt breaks on the upgrade leaving the instance in an unstable state.

Assuming the jessie image is build with jessie-wikimedia configured in apt, bootstrapping the image should come with our rsyslog version (8.1901.0-1~bpo8+wmf1) and thus creating a jessie instance would tentatively no more be broken.

Event Timeline

hashar created this task.Jul 3 2019, 8:14 AM
hashar added a project: Cloud-VPS.

Side node: you should try not building anything new with Jessie at this point.

hashar renamed this task from Please reubild Jessie base image due to rsyslog upgrade breakage to Please rebuild Jessie base image due to rsyslog upgrade breakage.Jul 3 2019, 9:34 AM

Side node: you should try not building anything new with Jessie at this point.

Definitely. We have to eventually upgrade to Stretch but it is going to take a few more months I guess :-\