Page MenuHomePhabricator

Structured Discussions show no toolbar or preview on Wikidata when "Enable the visual editor and the new wikitext mode in Structured Discussions" is disabled
Open, Needs TriagePublic

Description

https://www.mediawiki.org/wiki/Topic:V2g0amuhr2jetjoj

As discussed at the topic above, the Structured Discussions gadget does not provide any way to preview contributions. In particular, it does not show any toolbar. This makes it much less useful, and tends to result in many edited posts.

I have gone through the debugging steps at https://www.mediawiki.org/wiki/Help:Locating_broken_scripts without success.

Event Timeline

Bovlb created this task.Jul 3 2019, 10:41 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 3 2019, 10:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Bovlb added a comment.EditedJul 3 2019, 11:07 PM

Some more things I have established:

  • I can see the toolbar when I log out and access Wikidata as an IP user. This suggests that it is not a site-wide problem for all users.
  • When I log in in incognito mode, no toolbar is seen. This indicates that it is not caused by any browser extensions.
  • When I disable all Wikidata gadgets except Structured Discussions, I see no toolbar. This suggests that it is not caused by other gadgets.
  • Global JavaScript are empty. Clearing the local JavaScript does not cause the toolbar to appear.
Aklapper changed the task status from Open to Stalled.EditedJul 4 2019, 12:30 AM

Structured Discussions itself is not a gadget. :)

Please provide a link so someone else could try to reproduce the problem. See https://www.mediawiki.org/wiki/How_to_report_a_bug - thanks! Also, which browser is used?

Thanks. Cannot reproduce on https://www.wikidata.org/wiki/User_talk:Bovlb as I see the toolbar in Firefox 67 and being logged in...

Which browser do you use? Does this also happen with another browser?

Bovlb added a comment.EditedJul 4 2019, 4:00 AM

Which browser do you use?

Google Chrome
Version 75.0.3770.100 (Official Build) (64-bit)

Does this also happen with another browser?

I can also reproduce the problem in Safari Version 12.1 (14607.1.40.1.4), Firefox 63.0.3, or Firefox 67.0.4.

I cannot reproduce the problem with my secondary account. So it's beginning to look like the problem is something to do with my account.

I've tried on https://www.wikidata.org/wiki/User_talk:Bovlb?debug=true both with Chromium and Firefox and both with your content of https://www.wikidata.org/wiki/User:Bovlb/common.js and without, but could not reproduce.

So it's beginning to look like the problem is something to do with my account.

As I said, I was wondering if this is related to https://www.wikidata.org/wiki/User:Bovlb/common.js .
It might not be related but it's broken in the line importScript( 'MediaWiki:Gadget-statementSort.js]' ); due to the ].

Bovlb added a comment.Jul 4 2019, 3:36 PM

As I said, I was wondering if this is related to https://www.wikidata.org/wiki/User:Bovlb/common.js .
It might not be related but it's broken in the line importScript( 'MediaWiki:Gadget-statementSort.js]' ); due to the ].

Good catch. Unfortunately, I still experience the problem when I blank common.js.

JTannerWMF added a subscriber: JTannerWMF.

The Growth-Team will investigate the user's preferences then determine how to proceed.

Catrope closed this task as Invalid.Jul 9 2019, 8:04 PM
Catrope added a subscriber: Catrope.

As indicated in this comment, it's expected/documented behavior that if you disable VisualEditor in Flow, you will not see a toolbar or a preview button. This is because the preview is provided by switching to VisualEditor.

I turns out that the bug reporter did disable this preference; they can fix this for themselves by re-enabling this preference.

Aklapper renamed this task from Structured Discussions show no toolbar or preview on Wikidata to Structured Discussions show no toolbar or preview on Wikidata when "Enable the visual editor and the new wikitext mode in Structured Discussions" is disabled.Jul 9 2019, 8:55 PM

I have tried setting these two options, but it does not seem to change the behaviour.

Also, these options are unset in my secondary account, which does not experience the problem.

There is no indication on the "Structured Discussions on user talk" that it won't work correctly unless certain other options are set.

Bovlb reopened this task as Open.Sat, Aug 17, 12:10 AM

Is there any update on this? I've been trying out structured discussions on my talk page, but this lack of preview makes it very hard to use the tool effectively.