Page MenuHomePhabricator

File page: qualifiers not displayed just after they've been added
Closed, ResolvedPublic

Description

Steps to reproduce:

  • go to a File page with existing statements
  • add a qualifier to one of the statements, click 'publish'
  • the newly-added qualifier disappears when the panel switches back to read mode

Acceptance criteria:
Can be tested on https://commons.wikimedia.beta.wmflabs.org/wiki/File:Photo_on_08-02-2019_at_16.35.jpg

  • newly-added qualifier still shown when the panel switches back to read mode

QA Results

ACStatusDetails
1T227274#5347217

Details

Related Gerrit Patches:
mediawiki/extensions/WikibaseMediaInfo : masterDon't let OO.ui.mixin.GroupElement detach nodes from template

Event Timeline

Cparle created this task.Jul 4 2019, 12:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 4 2019, 12:42 PM
Cparle claimed this task.Jul 4 2019, 12:43 PM
Cparle moved this task from To Do to Doing on the Structured-Data-Team-Current-Work board.
Cparle added a comment.Jul 5 2019, 2:51 PM

Update: it looks like after you add a qualifier then just the first qualifier for all statements in the panel disappears.

Change 521247 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Don't let OO.ui.mixin.GroupElement detach nodes from template

https://gerrit.wikimedia.org/r/521247

Change 521247 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Don't let OO.ui.mixin.GroupElement detach nodes from template

https://gerrit.wikimedia.org/r/521247

matthiasmullie removed matthiasmullie as the assignee of this task.Jul 9 2019, 9:20 AM
matthiasmullie updated the task description. (Show Details)
matthiasmullie added a subscriber: matthiasmullie.
Cparle assigned this task to Edtadros.Jul 9 2019, 4:12 PM
Edtadros reassigned this task from Edtadros to Ramsey-WMF.Jul 18 2019, 6:53 PM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP

Test Artifact(s):

QA Steps

Acceptance criteria:
Can be tested on https://commons.wikimedia.beta.wmflabs.org/wiki/File:Photo_on_08-02-2019_at_16.35.jpg
✅ AC1: newly-added qualifier still shown when the panel switches back to read mode

Edtadros updated the task description. (Show Details)Jul 18 2019, 6:54 PM
Ramsey-WMF closed this task as Resolved.Jul 31 2019, 7:46 PM

Not a problem on production.