Page MenuHomePhabricator

Add skipcaptcha to all users from throttle-exempted IP addresses
Closed, ResolvedPublic

Description

I was told by @Vojtech.Vesely that this can be useful at certain wiki-events. Since users coming from throttle-exempted IP addresses should be generally trusted, this shouldn't be a problem IMHO.

Details

Related Gerrit Patches:

Event Timeline

Urbanecm created this task.Jul 8 2019, 2:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 8 2019, 2:35 PM

The ConfirmEdit extension includes wgCaptchaWhitelistIP, which can be used to do this.

Or, simply assign skipcaptcha in throttle-analyze.php in similar way we assign autoconfirmed there.

Change 523005 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Grant skipcaptcha to everyone coming from whitelisted IP

https://gerrit.wikimedia.org/r/523005

Urbanecm claimed this task.Jul 14 2019, 9:35 PM
Urbanecm added a project: User-notice.

No objections in a week after a wikitech-l notification so let's push things a little bit forward. Going to put this into next tech news draft, so everyone who might want to comment can do it.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJul 14 2019, 9:35 PM

I still have a problem with spambots attacking my database, which is broken currently and my server could not support anything for MediaWiki. I chose Simple English Wikipedia because it is like a fork of the English Wikipedia (like Uncyclopedia) except for that the articles are more simple.

@Znotch190711: I do not understand your last comment and how this is related to this task. If your comment is really related to implementing skipcaptcha to users in throttle-exempted then please explain how, and explain what is "your database" and how is your database related to Simple English Wikipedia. If it is not specifically related, then please see https://www.mediawiki.org/wiki/Manual:Combating_spam and https://www.mediawiki.org/wiki/Project:Support_desk - thanks!

Urbanecm renamed this task from Add skipcaptcha to all users from throttle-exempted to Add skipcaptcha to all users from throttle-exempted IP addresses.Jul 23 2019, 9:57 PM
Urbanecm moved this task from Archive to Announce in next Tech/News on the User-notice board.EditedAug 11 2019, 9:42 PM

Added into 34. Will happen on Wednesday.

Change 523005 merged by jenkins-bot:
[operations/mediawiki-config@master] Grant skipcaptcha to everyone coming from whitelisted IP

https://gerrit.wikimedia.org/r/523005

Mentioned in SAL (#wikimedia-operations) [2019-08-20T23:22:31Z] <urbanecm@deploy1001> Synchronized wmf-config/throttle-analyze.php: SWAT: a3927a7: Grant skipcaptcha to everyone coming from whitelisted IP (T227487) (duration: 00m 54s)

Urbanecm closed this task as Resolved.Aug 20 2019, 11:22 PM

Done!