Page MenuHomePhabricator

Requesting access to analytics-privatedata-users for mbsantos
Closed, ResolvedPublicRequest

Description

Username: mbsantos
Full name: Mateus Batista Santos

Reason: access Maps analytics for better maintenance planning.

SRE Clinic Duty Checklist for Shell Access Expansions

Most requirements are outlined on https://wikitech.wikimedia.org/wiki/Requesting_shell_access

This checklist should be used on all access requests to ensure that all steps are covered. This includes expansion to access. Please do not check off items on the list below unless you are in Ops and have confirmed the step.

  • - User has signed the L3 Acknowledgement of Wikimedia Server Access Responsibilities Document.
  • - User has a valid NDA on file with WMF legal. (This can be checked by Operations via the NDA tracking sheet & is included in all WMF Staff/Contractor hiring.)
  • - User has provided the following: existing shell username
  • - access request (or expansion) has sign off of WMF sponsor/manager (sponser for volunteers, manager for wmf staff) - yes via T227695#5324962
  • - 3 business day wait must pass with no objections being noted on the task
  • - both sudo and non sudo group additions are approved by the manager/team that handles that service group. - require @Nuria's approval per T227695#5333254
  • - Patchset for access request

Event Timeline

MSantos created this task.Jul 10 2019, 5:55 PM
Restricted Application added a project: Operations. · View Herald TranscriptJul 10 2019, 5:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@dr0ptp4kt and @JoeWalsh what do you think?

Approved as Engineering Director.

Adding @Nuria as the manager for analytics clusters.

A comment I have is that maybe turnilo or analytics-users would be sufficient instead of analytics-privatedata-users as the better maintenance planning reason given does not suggest an immediate advantage provided by having access to private data.

akosiaris triaged this task as Normal priority.Jul 15 2019, 1:51 PM
mpopov added a subscriber: mpopov.Jul 18 2019, 7:04 PM

The reason for private data access is that to investigate usage of the tile service (especially by parties outside of Wikimedia and our communities, which are the top users of the service), Mateus requires access to the webrequest table as that is the only place where he can look at the referrer info of tile requests.

herron assigned this task to Nuria.Jul 26 2019, 3:16 PM
RobH updated the task description. (Show Details)Jul 30 2019, 4:57 PM

@MSantos
what's the latest on this? Do you want to follow up on Nuria?

Approved on my end if employment and nda have been stablished. @MSantos Please read https://office.wikimedia.org/wiki/Data_access_guidelines and https://wikitech.wikimedia.org/wiki/Analytics/Systems/Cluster/Hive/Queries before doing queries.

Nuria added a comment.EditedAug 27 2019, 10:41 AM

mmm.. actually hold on, referrer info is available in turnilo for the tile service: please see: https://turnilo.wikimedia.org/#webrequest_sampled_128 and let us know if this is not sufficient

Thanks @Nuria, @mpopov and @Mathew.onipe.

mmm.. actually hold on, referrer info is available in turnilo for the tile service: please see: https://turnilo.wikimedia.org/#webrequest_sampled_128 and let us know if this is not sufficient

Cool, @mpopov and I were waiting for the approval so he can help me with the queries in the beginning.

@MSantos As i mentioned above you do not need queries, turnilo actually has that data, please see: https://turnilo.wikimedia.org/#webrequest_sampled_128

@Nuria maps200[1-4].codfw.wmnet and maps100[1-4].eqiad.wmnet don't seem to be available in turnilo, also tiles are requested from the domain maps.wikimedia.org and don't go through mediawiki. Are there any settings in turnilo that could provide them?

Nuria added a comment.Aug 27 2019, 2:49 PM

@MSantos Maps request are available in the dataset i linked to, here they are split by referrer: https://bit.ly/327pZde

Probably some time with @mpopov will help so you can get familiar with this dataset, from what you are saying turnilo should be sufficient for your request.

Nuria added a comment.Sep 3 2019, 7:20 AM

Closing as turnilo is indeed sufficient to gather the info requested

Nuria closed this task as Resolved.Sep 3 2019, 7:20 AM