Page MenuHomePhabricator

[wmf.13] Impact module: the tooltip displayed cut off
Closed, ResolvedPublic

Description

In cswiki go to Special:Imapct module for a user with edits that haven't been calculated in Pageviews yet.

The tooltip will be displayed as cut-off text:

<div class="oo-ui-clippableElement-clippable oo-ui-popupWidget-body oo-ui-popupWidget-body-padded" style=""><p>Protože jste tento článek poprvé editoval(a) teprve dnes, počet jeho zobrazení zatím nebyl vypočítán. Zkuste to zítra!</p></div>

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterImpact: fix no pageviews icon tooltip style

Event Timeline

Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptJul 11 2019, 8:01 PM
Etonkovidova moved this task from Inbox to Upcoming Work on the Growth-Team board.Jul 11 2019, 8:16 PM
Cntlsn added a comment.EditedJul 12 2019, 9:44 AM

The bug is also live on beta and test wiki.
There is an issue with some of the attributes of the .empty-pageviews class, also according to mockups the text should be left aligned.

This could do the job:

.empty-pageviews {
    white-space: normal;
    text-align: left;
}

I think the relevancy VS easy-fix ratio is good enough to be moved to "Ready for development".
Feel free to undo that.

This could do the job:

.empty-pageviews {
    white-space: normal;
    text-align: left;
}

It does! This is a relic of when we had "--" instead of the icon. We needed to make sure it was pushed to the right and that both dashes were on the same line. Both are irrelevant now that we have the icon. Also the values above are default for those properties so removing them completely works fine.

Change 522474 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Impact: fix no pageviews icon tooltip style

https://gerrit.wikimedia.org/r/522474

Aklapper renamed this task from [wmf.13] Impact module: the tooltip dipslayed cut off to [wmf.13] Impact module: the tooltip displayed cut off.Jul 12 2019, 6:20 PM

Change 522474 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Impact: fix no pageviews icon tooltip style

https://gerrit.wikimedia.org/r/522474

Etonkovidova closed this task as Resolved.Jul 22 2019, 11:59 PM

The issue is fixed: