Page MenuHomePhabricator

Copying and pasting table cell is broken in VisualEditor
Closed, ResolvedPublic

Description

Since few weeks copying and pasting table cell (Ctrl+C; Ctrl+V) in VE has been broken.
On paste it inserts new table with duplicated cells in target cell.

(See animated sequence; using ScreenToGif, if someone need it)

Using recent Chrome. Same issue on enwiki and lvwiki.

I am surprised it has not been noticed and could not find issue in phabricator. I think it is a different issue from T214624.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (e2f4b0e96)
VisualEditor/VisualEditor : masterRevert "Call handleInsertion on beforeinput"

Event Timeline

Papuass created this task.Jul 12 2019, 8:53 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJul 12 2019, 8:53 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Papuass updated the task description. (Show Details)Jul 12 2019, 8:54 AM
Papuass updated the task description. (Show Details)
Papuass updated the task description. (Show Details)
Papuass updated the task description. (Show Details)Jul 12 2019, 8:57 AM
XanonymusX added a comment.EditedJul 14 2019, 6:45 PM

This is incredibly annoying; even Wikipedians most critical about VE have always admitted that it is a good way to work with tables. Now not even that works anymore, it's so frustrating! At the moment apparently I have no way to copy and paste table columns.

To add some more details: the problem is the same whether I just select one table cell and want to insert a couple of cells (usually I would select the first cell of a column and insert the whole new column, which worked fine) or whether I select the whole column from the start ("overwriting" it with pasting the new column). It always ends up as a nested table. However, the result seems to be further broken, because when I try to reset the chaos by using Ctrl+Z, the nested table remains the same and results not editable. Something is very, very wrong.

A few more notes:

  • As XanonymusX mentions, Ctrl+Z can not be used to revert change
  • Cell content can be pasted successfully, if you select it by marking it with selection cursor (way slower action).
JTannerWMF added a subscriber: JTannerWMF.

We will take a look at this.

Per the merged task, this works correctly in Edge, so maybe it's a browser-specific problem.

Change 523770 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Revert "Call handleInsertion on beforeinput"

https://gerrit.wikimedia.org/r/523770

Change 523770 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Revert "Call handleInsertion on beforeinput"

https://gerrit.wikimedia.org/r/523770

Change 524550 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (e2f4b0e96)

https://gerrit.wikimedia.org/r/524550

Change 524550 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (e2f4b0e96)

https://gerrit.wikimedia.org/r/524550

matmarex edited projects, added Skipped QA; removed Editing QA.Aug 9 2019, 4:55 PM
matmarex moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Sep 3 2019, 1:02 AM
ppelberg claimed this task.