Page MenuHomePhabricator

[BUG] In UploadWizard's warning to disallowed filenames, "more info" does not link to anything
Closed, ResolvedPublicBug

Description

Use https://commons.wikimedia.org/wiki/Special:UploadWizard . Try uploading any photo. Write Screenshot 2019-01-01 ab as your filename. A warning pops up. The (more info) button looks like a link but is just a decoy. The button is part of class="oo-ui-labelElement-label" .

(Fun fact: been reported many times
https://commons.wikimedia.org/wiki/Commons:Village_pump/Archive/2018/01#Filename_blokkage
https://commons.wikimedia.org/wiki/Commons:Help_desk/Archive/2018/12#Beginner_uploader_to_wikimedia,_question_about_error_messages
https://commons.wikimedia.org/wiki/User_talk:Wargaz#Middle_(Naming_convention) )

Event Timeline

Roy17 created this task.Jul 12 2019, 11:46 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptJul 12 2019, 11:46 AM
Restricted Application changed the subtype of this task from "Task" to "Bug Report". · View Herald Transcript
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I debugged a little bit because I remember this used to work back in the day when I wrote this code. :)

The problem is caused by this change: rEUWI735f930c4eb4: Add params to warning messages about present-day public domain uploads – changing parseDom() to parse() causes the event handler on the "more info" link to be lost.

Change 522523 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/UploadWizard@master] uw.ValidationMessageElement: Fix error messages with buttons/links

https://gerrit.wikimedia.org/r/522523

Change 522523 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] uw.ValidationMessageElement: Fix error messages with buttons/links

https://gerrit.wikimedia.org/r/522523

matmarex closed this task as Resolved.Jul 12 2019, 8:31 PM
matmarex claimed this task.

The fix will be deployed to Wikimedia wikis per the usual schedule next week, with MediaWiki version 1.34.0-wmf.14. It will arrive on Commons on Wednesday, 17 July.

Thank you for reporting the issue!