Page MenuHomePhabricator

Investigate 2019-07-11 page load time regression on mobile (1.34-wmf.13)
Closed, ResolvedPublic

Description

Here seems to be a fairly confident +50ms regression on page load time (at the 75th percentile).

Found through navtiming-loadEventEnd, but also seen under:

  • navtiming-domComplete (same amount: ~ +50ms)
  • mediaWikiLoadEnd (more affected: ~ +80ms)
  • navtiming-processing (same amount: ~ +50ms)

See also https://wikitech.wikimedia.org/wiki/Performance/Metrics#navtiming-2_metrics for the definitions of these metrics.

Event Timeline

Krinkle created this task.Jul 12 2019, 6:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 12 2019, 6:29 PM
Jdlrobson moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

Note: The CSS that spiked in T227929 was subject to caching however SWATs on 15th and 16th would have reduced the CSS payload for most users.
https://grafana.wikimedia.org/d/000000326/navigation-timing-alerts?refresh=5m&orgId=1&panelId=19&fullscreen&from=now-7d&to=now does seem to be in decline now @Krinkle - do you think this was the cause?

Jdlrobson closed this task as Resolved.Jul 24 2019, 11:09 PM

Lemme know if you think this needs further investigation.