Page MenuHomePhabricator

http://tiles.wmflabs.org/osm/slippymap.html not showing OSM credits
Closed, ResolvedPublicBUG REPORT

Description

I have been warned by a friend from the OSM community that slippymap is in breach of the OSM copyright, for reusing the map without showing the attribution required by OSM. Furthermore, it is being reused from slippymap by 3rd parts, including the Environment Secretary of Azores, consequently not showing the attribution (as it's not shown in slippymap in first place)
I'm not sure if this is the proper place to fill a bug about slippymap, but I've seen some have already filled in the past, so here it is. If it is not the proper place, I hope someone can provide some advice about where to post this bug.

Steps to Reproduce:
Just go to http://tiles.wmflabs.org/osm/slippymap.html ant check, there is no attribution as required by OSM

Actual Results:
Attribution is lacking, the tool is in breach of OSM licensing terms

Expected Results:
Attribution to OSM is properly shown, as required by licensing terms

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 12 2019, 11:05 PM
Darwinius added a subscriber: User-TheDJ.
Aklapper renamed this task from Slippymap not showing OSM credits to http://tiles.wmflabs.org/osm/slippymap.html not showing OSM credits.Jul 13 2019, 7:55 AM
Darwinius updated the task description. (Show Details)Jul 13 2019, 11:53 AM
TheDJ closed this task as Resolved.Jul 13 2019, 5:34 PM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

Fixed, this was lost at some point probably due to switching from .OSM to .XYZ layers, which caused it to loose the automatic attribution.

TheDJ removed a project: Maps.Jul 13 2019, 5:41 PM

Note that this thing isn't really meant to be used in the first place ;)
It's more a test page for the tiles renderer, and people tend to embed the maps directly in their own copies of openlayers and leaflet