Flickr2commons has stopped working since the upload bug a week ago
Closed, ResolvedPublic

Description

Author: pku

Description:
Flickr2commons works as normal. It tells that the file should be on commons, and it gives a link to edit categories etcetera. But the file on commons does not exist.

My most recent try tonight ended like this:

Uploaded successfully.
Everything seems to be OK. Log will be written to /tmp/f2c_K4aqLm-dir/debug.txt.

[[Image:StGeorge church ruin.jpg|thumb|StGeorge church ruin.]]

Now check the new image has good categories!

For commons, this is a critical problem. See the village pump on commens, and search for "flickr2commons".


Version: unspecified
Severity: major
URL: http://toolserver.org/~magnus/flickr2commons.php

Details

bzimport set Reference to bz20815.
brion added a comment.Sep 28 2009, 7:14 PM

This is one of Magnus's tools... Magnus can you take a peek and help debug this? Most other tools seem to have been fixed by relaxing the token check to match previous form validation, but I guess this one's still broken somehow.

pku wrote:

I now noticed that something does get transferred to commons by Flickr2commons. When I later tried to upload using the upload form, I got a message that the file name was occupied.

Magnus added a comment.Oct 3 2009, 9:48 PM

Apparently, it broke when the Commons upload system was changed ever so slightly. Should be fixed now.

pku wrote:

Yes, I can confirm that it works now. However, one new problem was introduced: Flickr2commons now changes foreign characters in the description field into question marks on Commons.

bugs wrote:

(In reply to comment #4)

Yes, I can confirm that it works now. However, one new problem was introduced:
Flickr2commons now changes foreign characters in the description field into
question marks on Commons.

Please create a new bug for this.

Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 4 2014, 10:49 AM

Add Comment