Page MenuHomePhabricator

Footer is hidden if the page is too long
Closed, InvalidPublic

Description

If the page is too long (example on the French Wiktionary) ,then the footer text is covered by the page content.

Event Timeline

Pamputt created this task.Jul 17 2019, 2:11 PM

shows the issue

Isarra added a subscriber: Isarra.Jul 17 2019, 2:30 PM

Couple questions:

  • What browser is this?
  • Are you using any gadgets or other scripts that might affect this part of the content?
  • Does this happen on long content pages? Can you link one if so? (Probably a lot easier to debug there.)
  • Does it happen while logged out? (Probably check this before trying to think of any possibly relevant scripts, since this could rule a lot of them out regardless)

Hmmm, it is weird, I am not able to reproduce anymore. I was using Firefox ESR 60.0.8. The page was stable (I could scroll and see this effect) but when I reloaded the page, the bug dissapeared. So maybe it was a cache issue or something similar.

Nirmos added a subscriber: Nirmos.Jul 17 2019, 4:52 PM

Can't reproduce the problem in Firefox, Chrome or Edge. User:Pamputt/common.js contains a lot of old junk.

importScript('Utilisateur:Moyogo/latin_étendu.js');

gives "JQMIGRATE: jQuery.fn.bind() is deprecated".

importScript('Utilisateur:ArséniureDeGallium/vector.js');

gives "ReferenceError: hookEvent is not defined".

None of that seems to cause the problem, though, so it's probably a gadget, but you should probably remove that anyway. Once you've done that you should be able to just disable one gadget at a time and reload the page in between. That way you can figure out which one it is.

Isarra closed this task as Invalid.Jul 17 2019, 5:31 PM

All right, cool. If you run into it again, check logged out, hard refresh, etc and let us know if it doesn't go away that time?

Thanks for the report and looking into it!