Page MenuHomePhabricator

Universal Language Selector does not detect the language of page content
Closed, InvalidPublic

Description

Hi everyone,

I use the ULS package in my Wiki together with the translate package and for the page contents etc. it works fine. But if the language is set to e.g. German and i click the Wiki-Logo, which leads to the English Main Page, the ULS is still set to German and not english. So also the sidebar contents remain german. Is this a bug or am i doing something wrong?

And one question off topic. Is it possible to have the ULS also in the sidebar like the extension "LanguageSelector" ? It would look so much better and would improve the handling as well.

Hopefully some of you have some advice.

Thanks in advance.

Best regards!

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 19 2019, 10:42 AM

Hi @Seehausen, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

Which exact MediaWiki and exact UniversalLanguageSelector versions are used?

But if the language is set to e.g. German

Where exactly? In your user's settings? Somewhere on the website? In your web browser's settings? Please see https://www.mediawiki.org/wiki/How_to_report_a_bug and provide a clear list of steps that allow someone else to reproduce your exact setup - thanks!

(I don't see how this is related to Containers, hence adding UniversalLanguageSelector.)

Hi @Aklapper

sorry about the inconvenience due to my first entry here.

Additional Information to the versions:

MediaWiki-Version: 1.32.2
UniversalLanguageSelector 1.33 (2018-07-10 (dd390d2) 15:07, 11. Okt. 2018)

Regarding your cite:

If i open my Wiki in a browser and select a language (e.g. German) with the ULS-button in the Wiki and click afterwards on the Wiki-Logo, which leads to the English Main Page, the ULS is still set to German and not english. So also the sidebar contents remain german.

Hopefully that is enough information.

Best regards

Seehausen updated the task description. (Show Details)Jul 22 2019, 11:39 AM

When we say language in the context of wiki, there is a"interface language" - the language of user interface and then content language- that is the content language of wiki. So if you are in germal wikipedia, the content language is german. But the interface language can be anything(for example English). If interface language is English, the items in sidebar, top menu etc will be in English.

ULS is a generic language selector. Using that you can choose interface language. With the help of interlanguage link and ULS compact links feature, you can choose a content language. These features are explained in detail at https://www.mediawiki.org/wiki/Universal_Language_Selector and https://www.mediawiki.org/wiki/Universal_Language_Selector/FAQ

Aklapper closed this task as Invalid.Jul 24 2019, 9:06 AM

Closing this task as invalid as per last comment, as there seems to be a misunderstanding between interface language and page language.

Please set the status of this report back to "Open" via the Add Action...Change Status dropdown if I misunderstood. Thanks!