Page MenuHomePhabricator

Termbox browser tests blocking merges in Minerva
Closed, ResolvedPublic

Description

Have had about 5 of these today:

11:15:41 [chrome #0-17] 1) license agreement "before each" hook for "disappears, after clicking cancel and goes back to Editmode":
11:15:41 [chrome #0-17] An element could not be located on the page using the given search parameters (".wb-ui-event-emitting-button--edit").
11:15:41 [chrome #0-17] Error: An element could not be located on the page using the given search parameters (".wb-ui-event-emitting-button--edit").
11:15:41 [chrome #0-17]     at click() - index.js:312:3

Please disable this test or don't run it in the shared builds as we can't force merge in Minerva. Thanks in advance.

I think this is caused by T225196 and probably because Minerva browser tests run without Vector installed.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 22 2019, 6:31 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 22 2019, 6:31 PM

Also seeing the related:

11:43:32 1) Termbox Readmode Expandable/Collapsable Elements All-Entered-Languages is collapsed after clicking All-Entered-Languages button twice "before all" hook:
11:43:32 An element could not be located on the page using the given search parameters (".wb-ui-all-entered-languages-expandable__switch").
11:43:32 running chrome

so seems to not be isolated to one of these tests.

Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: zeljkofilipin.
Michael claimed this task.Jul 23 2019, 7:55 AM
Michael added a project: Patch-For-Review.

Created a patch which should revert the commit that added the browser tests to CI: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/525037

Restricted Application added a project: User-Michael. · View Herald TranscriptJul 23 2019, 7:55 AM

As far as I can see this is probably more a flapping test rather than a failure due to lack of Vector.

Looks like the patch listed succeeded in being merged before the revert was in place: https://gerrit.wikimedia.org/r/c/mediawiki/skins/MinervaNeue/+/524820/#message-a5fbf5bbc29cdbd9e64ad17b9dc78518f5fa5569

Also looks like Vector is installed in that test run: grep for 18:35:25 INFO:zuul.CloneMapper: mediawiki/skins/Vector -> /workspace/src/skins/Vector in the log: https://integration.wikimedia.org/ci/job/wmf-quibble-vendor-mysql-hhvm-docker/31301/consoleFull

Michael removed Michael as the assignee of this task.Jul 23 2019, 8:56 AM
Michael lowered the priority of this task from Unbreak Now! to High.
Michael removed a project: Patch-For-Review.

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/525037 is merged now, so lowering priority as this should no longer block anyone anymore. Feel free to raise this again if it is still an issue.

Change 525050 had a related patch set uploaded (by Tarrow; owner: Tarrow):
[wikibase/termbox@master] Use document.readyState for browser test waitForPageToLoad

https://gerrit.wikimedia.org/r/525050

Change 525109 had a related patch set uploaded (by Jakob; owner: Jakob):
[wikibase/termbox@master] Browser tests: ensure termbox is loaded before starting interaction

https://gerrit.wikimedia.org/r/525109

Thanks all for the speedy response!

Change 525109 merged by jenkins-bot:
[wikibase/termbox@master] Browser tests: ensure termbox is loaded before starting interaction

https://gerrit.wikimedia.org/r/525109

Change 528128 had a related patch set uploaded (by Jakob; owner: Jakob):
[mediawiki/extensions/Wikibase@master] Update termbox

https://gerrit.wikimedia.org/r/528128

Change 528128 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Update termbox

https://gerrit.wikimedia.org/r/528128

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:06 PM

Change 525050 abandoned by Tarrow:
Use document.readyState for browser test waitForPageToLoad

https://gerrit.wikimedia.org/r/525050

Ladsgroup closed this task as Resolved.Oct 23 2019, 11:12 AM
Ladsgroup claimed this task.
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptOct 23 2019, 11:12 AM
Restricted Application added a subscriber: Masumrezarock100. · View Herald Transcript