Page MenuHomePhabricator

HttpStatus.php: PHP Warning: Unknown HTTP status code default
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error

Request URL: https://www.mediawiki.org/w/api.php
Request ID: XTcLYQpAMEIAAG0SiC0AAACO

message
[{exception_id}] {exception_url}   ErrorException from line 100 of /srv/mediawiki/php-1.34.0-wmf.15/includes/libs/HttpStatus.php: PHP Warning: Unknown HTTP status code default
trace
 #0 /srv/mediawiki/php-1.34.0-wmf.15/includes/libs/HttpStatus.php(100): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.34.0-wmf.15/includes/WebResponse.php(106): HttpStatus::header(string)
#2 /srv/mediawiki/php-1.34.0-wmf.15/includes/api/ApiFormatBase.php(181): WebResponse->statusHeader(string)
#3 /srv/mediawiki/php-1.34.0-wmf.15/includes/api/ApiMain.php(1827): ApiFormatBase->setHttpStatus(string)
#4 /srv/mediawiki/php-1.34.0-wmf.15/includes/api/ApiMain.php(598): ApiMain->printResult(string)
#5 /srv/mediawiki/php-1.34.0-wmf.15/includes/api/ApiMain.php(538): ApiMain->handleException(Flow\Exception\FailCommitException)
#6 /srv/mediawiki/php-1.34.0-wmf.15/includes/api/ApiMain.php(502): ApiMain->executeActionWithErrorHandling()
#7 /srv/mediawiki/php-1.34.0-wmf.15/api.php(86): ApiMain->execute()
#8 /srv/mediawiki/w/api.php(3): include(string)
#9 {main}

Impact

TBD.

Notes

I don't have the PHP understanding to determine if this is a train blocker. Just in case, I'm marking it as one. If it isn't, please tell me. Thanks.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 23 2019, 1:49 PM
LarsWirzenius triaged this task as Unbreak Now! priority.Jul 23 2019, 1:50 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 23 2019, 1:50 PM
Anomie added a subscriber: Anomie.

Tagging for Platform Team Workboards (Clinic Duty Team) since this is marked as an UBN in MediaWiki code.

Anomie lowered the priority of this task from Unbreak Now! to Medium.Jul 23 2019, 2:05 PM

Looking in Kibana, I see exactly one occurrence of this message in the past 7 days: https://logstash.wikimedia.org/goto/6a59ad49a82dbe63361b417f0a66a74b

Expanding it to any "Unknown HTTP status code" message, there are 9 in the past 7 days: https://logstash.wikimedia.org/goto/f20a7ea40597afacb385bb3037291d40

On that basis, this does not seem to be serious enough to block the train. Untagging as a train blocker and reducing priority accordingly. Feel free to re-increase it if this starts occurring more widely.

Change 525099 had a related patch set uploaded (by Anomie; owner: Anomie):
[mediawiki/core@master] API: Only take HTTP code from ApiUsageException

https://gerrit.wikimedia.org/r/525099

Anomie claimed this task.Jul 23 2019, 2:25 PM
Anomie moved this task from Unsorted to Needs Review on the MediaWiki-API board.

Looking in Kibana, I see exactly one occurrence of this message in the past 7 days: https://logstash.wikimedia.org/goto/6a59ad49a82dbe63361b417f0a66a74b

Thanks for the quick triage, not a blocker indeed.

Do note that this was filed as regression because Unknown HTTP status code default had not been seen in the past. It was found new today, on 1.34.0-wmf.15, which had only been live for a few minutes on group0 at the time (so the 6 days prior are less relevant in that regard, other than to confirm it was indeed new).
Thanks!

Change 525099 merged by jenkins-bot:
[mediawiki/core@master] API: Only take HTTP code from ApiUsageException

https://gerrit.wikimedia.org/r/525099

Anomie closed this task as Resolved.Jul 26 2019, 3:11 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:06 PM
Aklapper removed a subscriber: Anomie.Oct 16 2020, 5:41 PM