Page MenuHomePhabricator

Some interface messages are default messages instead of local overrides for language variants on Chinese Wikipedia and Wikivoyage
Open, Needs TriagePublic

Description

There are some interface message displayed as default messages (from translatewiki) instead of local overrides.
Chinese Wikivoyage: pagetitle, sidebar, Sitetitle etc
Chinese Wikipedia: pagetitle-view-mainpage, mycontris. portal, about. sitesupport and so on. (Report on Village pump)

The interface messages of Wikivoyage are good and bad, but Sidebar has never recovered to what it should look like on the local side. It has been nearly two months, but there has been no sign of improvement...
Chinese Wikivoyage problem list:


Old description:
The normal display is 維基導遊,自由的旅遊指南 (Traditional Chinese ) or 维基导游,自由的旅游指南(Simplified Chinese), not should only display is 维基导游 , by the way, the problem has recently occurred, who can help improve?

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 24 2019, 1:43 PM

I can't reproduce the problem. The name of the page tab depends on [[MediaWiki:Pagetitle]].

Interestingly, when I looked at the page history of MediaWiki:Pagetitle/zh-tw, I found that the page was edited twice. The first edit content is $1 - 維基導遊 ($1 means that the title of the current page), then modified into $1 - 來自維基導遊的旅行指南.

Aklapper changed the task status from Open to Stalled.Jul 24 2019, 2:24 PM

Cannot reproduce in Firefox 68:

Which browser is used? Does this also happen in safemode?

@Aklapper I using Yandex browser, and I have try using Google Chrome browser, Google Chrome also shows abnormal phenomena.

Does this also happen in safemode?
Does this happen on all pages on zh.wikivoyage.org?

@Aklapper The safemode also shows abnormal phenomena, and this does happen on all pages on zh.wikivoyage.org

@RazeSoldier I don't think it's a problem with the Chinese Wikivoyage website. I think someone can change $1 or page name on elsewhere.

@Yuriy_kosygin Will you still encounter this phenomena after you log out?

@RazeSoldier Still the same after Log out...

By the way, the search bar 维基导游 cannot convert to 維基導遊 on the Traditional Chinese. I think the $1 is importent a problem.

A2093064 added a subscriber: A2093064.EditedJul 24 2019, 3:41 PM

I can reproduce it.
When I do a null edit on MediaWiki:Pagetitle and the title of any pages changed to correct title.
Not it's fixed but I don't know why.

I can reproduce it.
When I do a null edit on MediaWiki:Pagetitle and the title of any pages changed to correct title.
Not it's fixed but I don't know why.

Are you browsing in zh-tw content language?

Are you browsing in zh-tw content language?

Interface language: zh-Hant-TW
Content language variant: zh-Hant

A2093064 I have try using Yandex and Google Chrome browser, the display is normal, and I don't know why is MediaWiki:Pagetitle unintelligible and there are strange problems (no one has changed it recently)....

Although we don't know why, but it seems to be back to normal, so can I close this task?

well... I should close it.

Yuriy_kosygin closed this task as Resolved.Jul 24 2019, 4:17 PM

@Aklapper Sorry... I will note the close process next time.

Are you browsing in zh-tw content language?

Interface language: zh-Hant-TW
Content language variant: zh-Hant

The changes you made are for zh-tw content language, so you won't see any changes.

Although we don't know why, but it seems to be back to normal, so can I close this task?

No site configuration changes, no site interface page changes, I suspect the problem caused by the gadget (javascript can modify the page title). But I did not debug it carefully.

Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Jul 25 2019, 3:21 AM

The changes you made are for zh-tw content language, so you won't see any changes.

Interface message follow Interface language setting. And I use uselang=xxx to check it.

I suspect the problem caused by the gadget (javascript can modify the page title).

I don't think so. This bug still exists with safemode=1.

A2093064 renamed this task from The Chinese Wikivoyage tab name display error in browser to Some interface messages are displayed as default messages instead of local overrides on Chinese Wikipedia and Wikivoyage.Jul 25 2019, 3:53 PM
A2093064 reopened this task as Open.
A2093064 updated the task description. (Show Details)
Restricted Application added a subscriber: Cosine02. · View Herald TranscriptJul 25 2019, 3:53 PM

Reopen because I found same bug happen on zhwiki.

Aklapper renamed this task from Some interface messages are displayed as default messages instead of local overrides on Chinese Wikipedia and Wikivoyage to Some interface messages are default messages instead of local overrides for language variants on Chinese Wikipedia and Wikivoyage.Jul 25 2019, 6:04 PM

Same phenomenon...

Shizhao moved this task from Closed to Backlog on the Chinese-Sites board.Jul 29 2019, 3:17 AM

I've also noticed this. Could be reproduced under Chrome 75 and on Chinese Wikipedia.

Chrome 78 per above.

Cwek added a subscriber: Cwek.Jul 31 2019, 3:36 AM
Yuriy_kosygin added a comment.EditedAug 1 2019, 2:17 PM

Sorry... Wikivoyage also problem again, and not fixed...

Shizhao added a subscriber: Shizhao.Aug 2 2019, 3:47 AM

T229339 also same problem?

T229339 also same problem?

Umm.... I think also problem, because I also find many MediaWiki have display problem....

MediaWiki is maybe problem, but in local is no change, who can fix it in MediaWiki?

I think this problem only appears on some wikis. In my development environment, I can't reproduce this problem.

Yuriy_kosygin added a comment.EditedAug 5 2019, 1:36 PM

But I using Yandex and Google Chrome browser find sidebar and search bar is problem, and many Simplified Chinese user also find same problem(Via Telegram group feedback)...

And it’s sometime good and sometime bad phenomenon.

I can reproduce the problem that pagetitle wrong when I set my interface language to zh. [[MediaWiki:Pagetitle/zh]] is the default message, but this should not be the cause of the problem, because wgLanguageCode for zhwiki is zh, and [[MediaWiki:Pagetitle]] will cover [[MediaWiki:Pagetitle/zh]]. But I don't know why the coverage didn't take effect.

Yuriy_kosygin added a comment.EditedAug 5 2019, 2:08 PM

Umm... I have try to reproduce MediaWiki:Sidebar and MediaWiki:Pagetitle(I think include search bar name) on Wikivoyage, but no fixed successful.

Yuriy_kosygin updated the task description. (Show Details)Aug 6 2019, 1:53 PM
Yuriy_kosygin updated the task description. (Show Details)

Who can help reproduce the MediaWiki code?

click https://zh.wikipedia.org/wiki/Special:%E9%9A%8F%E6%9C%BA%E9%A1%B5%E9%9D%A2 (random page), click 10 times, 5 times nstab-main display as "页面", 5 times display as "条目"

Viztor added a subscriber: Viztor.

I can reproduce the problem that pagetitle wrong when I set my interface language to zh. [[MediaWiki:Pagetitle/zh]] is the default message, but this should not be the cause of the problem, because wgLanguageCode for zhwiki is zh, and [[MediaWiki:Pagetitle]] will cover [[MediaWiki:Pagetitle/zh]]. But I don't know why the coverage didn't take effect.

This is likely due to T229992, you must have set all MediaWiki:MSG/variants to overwrite, even if it has set a fallback variant

Shizhao added a project: HHVM.EditedAug 8 2019, 8:57 AM

Test Results:

  • Normal page ( nstab-main display as "条目" ): x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1
  • Anomalous page ( nstab-main display as "页面" ): x-powered-by: HHVM/3.18.6-dev

I have to say that MediaWiki.org also has this problem. The sidebar I saw was completely different from what I saw before. (I use zh as my interface language)

Maybe we should consider the impact of this ticket, it seems to affect multiple sites.

Sunny00217 added a comment.EditedAug 10 2019, 2:31 PM

Test Results:

  • Normal page ( nstab-main display as "条目" ): x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1
  • Anomalous page ( nstab-main display as "页面" ): x-powered-by: HHVM/3.18.6-dev

This mean we using HHVM and having this error? BTW,some time Tags php7 (PHP7) will show in Tags,but some time it didn't work,like https://zh.wikipedia.org/w/index.php?title=Wikipedia:沙盒&action=history

Test Results:

  • Normal page ( nstab-main display as "条目" ): x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1
  • Anomalous page ( nstab-main display as "页面" ): x-powered-by: HHVM/3.18.6-dev

This mean we using HHVM and having this error? BTW,some time Tags php7 (PHP7) will show in Tags,but some time it didn't work,like https://zh.wikipedia.org/w/index.php?title=Wikipedia:沙盒&action=history

As I've said in T229379, this has nothing to do with hhvm/php7.

Sunny00217 added a comment.EditedAug 11 2019, 6:11 AM

Test Results:

  • Normal page ( nstab-main display as "条目" ): x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1
  • Anomalous page ( nstab-main display as "页面" ): x-powered-by: HHVM/3.18.6-dev

This mean we using HHVM and having this error? BTW,some time Tags php7 (PHP7) will show in Tags,but some time it didn't work,like https://zh.wikipedia.org/w/index.php?title=Wikipedia:沙盒&action=history

As I've said in T229379, this has nothing to do with hhvm/php7.

Than why error show on x-powered-by: HHVM/3.18.6-dev(HHVM) but not in x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1(PHP7)?

Yuriy_kosygin added a comment.EditedAug 14 2019, 2:59 PM

It's big trouble.... Is this a problem due to updating MediaWiki?

Test Results:

  • Normal page ( nstab-main display as "条目" ): x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1
  • Anomalous page ( nstab-main display as "页面" ): x-powered-by: HHVM/3.18.6-dev

This mean we using HHVM and having this error? BTW,some time Tags php7 (PHP7) will show in Tags,but some time it didn't work,like https://zh.wikipedia.org/w/index.php?title=Wikipedia:沙盒&action=history

As I've said in T229379, this has nothing to do with hhvm/php7.

Than why error show on x-powered-by: HHVM/3.18.6-dev(HHVM) but not in x-powered-by: PHP/7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82+wmf1(PHP7)?

It seems that there is nothing to do with PHP engines. The randomness of the interface error has made me think of that if there is any problem in Varnish.

Is it because there is something updated in July, which will cause this problem? If so, can try to fall back to the part before July?

Before discussing when the change is causing the problem, we first need to find the time to first discover the problem. The start time for the problem may much earlier than this ticket was created.

So far, there has been no improvement. What is the progress now?

For the start, a clear description with clear steps to reproduce, expected behavior, and actual behavior, as a list of bullet-point steps, would be very welcome.
You can edit the task description by clicking Edit Task.

I have already written, this is already the problem that is currently unresolved.

And as I already wrote, we need a list of clear steps to reproduce that allow anyone else to follow that list of steps to see the problem. Thanks :)

I have update description, please help fix it, thanks.

Nobody can fix it if you do not provide clear steps that allow other people to see and reproduce a problem...
I've asked for clear steps several times here, but my requests are ignored in this task. https://www.mediawiki.org/wiki/How_to_report_a_bug

Nobody can fix it if you do not provide clear steps that allow other people to see and reproduce a problem...
I've asked for clear steps several times here, but my requests are ignored in this task. https://www.mediawiki.org/wiki/How_to_report_a_bug

Just implement anything that could be described by the following pseudocode, and you'll reproduce the problem:

do
{
     pagehtml=gethtmlbyurl("https://zh.wikipedia.org/wiki/Special:Random");
 }while (! pagehtml contains the substring "来自Wikipedia");
 print pagehtml;

Expected behavior: infinite loop, as "来自Wikipedia" is the default interface message, which should always be overridden by local settings.
Oberserved behavior: The loop terminates after a few minutes, hence the problem.