Page MenuHomePhabricator

"Internal error: Server failed to store temporary file" when trying to upload images with upload wizard
Closed, ResolvedPublic

Description

One fellow user in Munich reported that he often can't upload images with with the upload wizzard. He tried multiple times and with different browsers. See screenshot for an example:

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptJul 24 2019, 7:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Aklapper renamed this task from Bug uploading images with upload-wizzard to "Internal error: Server failed to store temporary file" when trying to upload images with upload wizard.Jul 24 2019, 8:01 PM
Aklapper added a project: SRE-swift-storage.

Likely the same as T228292.

If it can be useful: a 10240 KB jpg fill will upload but a 10269 KB jpg file will not.
It looks like the "Internal error: Server failed to store temporary file." message starts at around 10269KB

Please solve this task as a priority. We stopped work.

I couldn't upload more than 50 photos due to this problem.

GiorgioGaleotti triaged this task as Unbreak Now! priority.Jul 29 2019, 9:27 PM

I don't know if I can do this, but I've changed the status to Ubreak Now since it's been impossible to upload anything larger than 10MB since about a week!

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 29 2019, 9:27 PM

@hashar Any thoughts/help you can provide on this would be appreciated :) I think Matthias addressed this last time around but he's on vacation now.

All I can say, as a user, is that the problem starts at around 10MB files.

I tried uploading a 10563 KB PNG and a 11105 KB JPEG, and couldn't reproduce the problem. I didn't publish them, but I understand the problem occurs after the initial upload.

T228292 is not related, the most recent log entry matching "UploadChunkFileException" was July 24, which is too long ago to explain these reports.

I think this is consistent with T228749. The error seen in the screenshot is api-error-stashfailed, which can only be generated by AssembleUploadChunksJob when it catches an exception. There are plenty of log entries. I'll cherry-pick the fix.

Mentioned in SAL (#wikimedia-operations) [2019-07-30T05:23:46Z] <tstarling@deploy1001> Synchronized php-1.34.0-wmf.15/includes/upload/UploadBase.php: T228929 (duration: 00m 48s)

Mentioned in SAL (#wikimedia-operations) [2019-07-30T05:24:33Z] <tstarling@deploy1001> Synchronized php-1.34.0-wmf.15/includes/api/ApiUpload.php: T228929 (duration: 00m 47s)

Mentioned in SAL (#wikimedia-operations) [2019-07-30T05:25:20Z] <tstarling@deploy1001> Synchronized php-1.34.0-wmf.15/includes/jobqueue/jobs/AssembleUploadChunksJob.php: T228929 (duration: 00m 46s)

tstarling closed this task as Resolved.Jul 30 2019, 5:34 AM

I'm pretty sure it's fixed, although there's not enough log traffic to be completely sure. Please reopen this task if you see this kind of upload failure again within the next few days.

Note that existing UploadWizard sessions may have been broken. If an upload was in progress at the time of the stashbot log entries above, you may need to restart it.