Page MenuHomePhabricator

Deletion of limn-edit-data repository
Closed, ResolvedPublic

Description

Hi @mforns @Milimetric @Jdforrester-WMF

As announced, we've moved the queries in this repo to reportupdater-queries.

There are still a bunch of directories in this repo that don't appear to have changed in the last 2-5 years, and I wanted to know if these files are valuable to you or we can clean this repo up.

Thank you!

Details

Related Gerrit Patches:
analytics/limn-edit-data : masterArchive repository

Event Timeline

fdans created this task.Jul 25 2019, 10:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2019, 10:41 AM

The limn-edit-data/edit/ folder contains several RU queries and config, however they are not currently scheduled in puppet for execution.
I think those are the reports used in the old compare Wikitext vs VisualEditor dashboard that we disabled a couple years ago.
I don't think we'll use those again, but let @Jdforrester-WMF decide.

Regarding the other 2 folders, scripts and dashboard, seem even older, I think they are limn config, so, almost sure we can delete them.

That's @Neil_P._Quinn_WMF and @ppelberg's call, I'm not the product owner or analyst any more. :-)

fdans triaged this task as High priority.Jul 25 2019, 4:42 PM
fdans moved this task from Incoming to Operational Excellence on the Analytics board.
nshahquinn-wmf added a comment.EditedJul 30 2019, 1:31 PM

Thanks for the ping @Jdforrester-WMF!

@mforns, I have a feeling that we can get rid of everything you mention. However, where should I look to see them? I don't see them in the analytics-reportupdater-queries repo.

@Neil_P._Quinn_WMF they weren't migrated, they only exist in the old repo: https://github.com/wikimedia/analytics-limn-edit-data

fdans added a comment.Aug 12 2019, 5:51 AM

@Neil_P._Quinn_WMF anything else you think should be saved here?

https://github.com/wikimedia/analytics-limn-edit-data

@fdans I checked it over and we can archive/delete it—there's nothing we need to keep.

Nuria added a subscriber: Nuria.Aug 21 2019, 4:17 PM

Repo can be archived then, tagging Release-Engineering-Team to archive this repo

Nuria moved this task from Operational Excellence to Radar on the Analytics board.Aug 25 2019, 9:37 AM

This appears to be a duplicate of T228981 but pinging different users...?

fdans added a comment.Sep 12 2019, 3:17 PM

@TheSandDoctor nope. This task is regarding the deletion of https://github.com/wikimedia/analytics-limn-edit-data

The task you mention is for the deletion of https://github.com/wikimedia/analytics-limn-flow-data

@TheSandDoctor nope. This task is regarding the deletion of https://github.com/wikimedia/analytics-limn-edit-data
The task you mention is for the deletion of https://github.com/wikimedia/analytics-limn-flow-data

Oops. Thanks!

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptSun, Dec 29, 7:22 PM

Mentioned in SAL (#wikimedia-releng) [2019-12-29T20:34:39Z] <hauskatze> github: Mirror deleted: "wikimedia/analytics-limn-edit-data" (T228982)

Change 561097 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[analytics/limn-edit-data@master] Archive repository

https://gerrit.wikimedia.org/r/561097

Change 561097 merged by MarcoAurelio:
[analytics/limn-edit-data@master] Archive repository

https://gerrit.wikimedia.org/r/561097

MarcoAurelio closed this task as Resolved.Sun, Dec 29, 8:42 PM
MarcoAurelio moved this task from working on to cabinet on the User-MarcoAurelio board.