Page MenuHomePhabricator

Unit tests are not being run for extensions under PHPUnit 4.x (HHVM)
Closed, DeclinedPublicBUG REPORT

Description

Steps to Reproduce:

Actual Results:

INFO:quibble.commands:PHPUnit unit tests
INFO:quibble.commands:composer phpunit:unit -- --exclude-group Broken,ParserFuzz,Stub --log-junit /workspace/log/junit-unit.xml
> phpunit --colors=always --testsuite=core:unit,extensions:unit,skins:unit '--exclude-group' 'Broken,ParserFuzz,Stub' '--log-junit' '/workspace/log/junit-unit.xml'
PHPUnit 4.8.36 by Sebastian Bergmann and contributors.



Time: 218 ms, Memory: 6.21MB

No tests executed!

Expected Results:

Unit tests for core, extensions and skin to be run, and to take ~5 seconds.

Event Timeline

kostajh created this task.Jul 29 2019, 12:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2019, 12:11 PM
kostajh renamed this task from Unit test are not run for extensions to Unit tests are not run for extensions.Jul 29 2019, 12:11 PM

Seems related to the PHPUnit version.

https://integration.wikimedia.org/ci/job/quibble-vendor-mysql-hhvm-docker/61820/

INFO:quibble.commands:PHPUnit unit tests
INFO:quibble.commands:composer phpunit:unit -- --exclude-group Broken,ParserFuzz,Stub --log-junit /workspace/log/junit-unit.xml
> phpunit --colors=always --testsuite=core:unit,extensions:unit,skins:unit '--exclude-group' 'Broken,ParserFuzz,Stub' '--log-junit' '/workspace/log/junit-unit.xml'
PHPUnit 4.8.36 by Sebastian Bergmann and contributors.



Time: 218 ms, Memory: 6.21MB

No tests executed!

In the same build set, a php 7.2 based job ran the tests https://integration.wikimedia.org/ci/job/quibble-vendor-mysql-php72-docker/15210/

INFO:quibble.commands:PHPUnit unit tests
INFO:quibble.commands:composer phpunit:unit -- --exclude-group Broken,ParserFuzz,Stub --log-junit /workspace/log/junit-unit.xml
> phpunit --colors=always --testsuite=core:unit,extensions:unit,skins:unit '--exclude-group' 'Broken,ParserFuzz,Stub' '--log-junit' '/workspace/log/junit-unit.xml'
PHPUnit 6.5.14 by Sebastian Bergmann and contributors.

.............................................................   61 / 3920 (  1%)
...
Jdforrester-WMF renamed this task from Unit tests are not run for extensions to Unit tests are not run being for extensions under PHPUnit 4.x (HHVM).Jul 29 2019, 9:41 PM
Jdforrester-WMF triaged this task as High priority.

Ah. Well as long as they run in one job then I think it’s ok to decline this task, since e.g. the php72 job would tell us if a test extended the unit test case but it tried to call setMwGlobals()

Unit tests are being run with the legacy PHPunit entrypoint; what the plain entrypoint gives us is a bootstrap.php file which ensures no globals are loaded.

Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Proposing to the RelEng TODO board so that we make an official decision whether or not to Decline.

Krinkle renamed this task from Unit tests are not run being for extensions under PHPUnit 4.x (HHVM) to Unit tests are not being run for extensions under PHPUnit 4.x (HHVM).Aug 7 2019, 1:21 PM
Krinkle moved this task from Inbox to PHPUnit on the MediaWiki-Core-Testing board.Sep 4 2019, 5:48 PM
kostajh closed this task as Declined.Oct 21 2019, 1:59 PM

HHVM is gone, so I'm marking this as declined.