Page MenuHomePhabricator

Random whitespace changes and duplicate URLs
Closed, DeclinedPublic

Description

https://en.wikipedia.org/w/index.php?title=Hamlet&diff=908184648&oldid=907947072&diffmode=source
https://en.wikipedia.org/w/index.php?title=William_Shakespeare&diff=908176129&oldid=908098002&diffmode=source

IABot made random changes to whitespace here (moving the |title parameter on the same line as the opening line of the template), as well as adding both a |url= parameter and adding external link syntax in the |pages parameter (it should do one or the other).

Event Timeline

Xover created this task.Jul 29 2019, 2:15 PM
Cyberpower678 closed this task as Resolved.Jul 31 2019, 4:10 AM

Whitespace issues fixed.

Xover reopened this task as Open.Aug 9 2019, 8:47 AM

Now it's inserting extra whitespace before the close brackets of the citation, and it's still inserting duplicate links in |url= and |pages=. See https://en.wikipedia.org/w/index.php?title=Hamlet&diff=909523776&oldid=909485888&diffmode=source

Cyberpower678 closed this task as Declined.Aug 9 2019, 11:31 AM

It follows the most used format in the found in the template and goes with it. Every parameter in the case has a space. The url duplicates is intended by design and is approved to do so.