Page MenuHomePhabricator

Logging out on web logs out iOS session
Closed, ResolvedPublicBUG REPORT

Description

How many times were you able to reproduce it?

10/10

Steps to reproduce

  1. Login on web (ideally as a user that has saved reading lists, helps to repro)
  2. Login on iOS as the same user
  3. Logout on web
  4. Pull to refresh reading lists on iOS

Expected results

User remains logged in on iOS, potentially re-logged in with keychain credentials

Actual results

User is logged out on iOS, needs to manually log back in

Event Timeline

JoeWalsh created this task.Jul 29 2019, 6:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2019, 6:47 PM
JMinor triaged this task as Medium priority.Jul 29 2019, 6:48 PM
Sbailey claimed this task.Aug 1 2019, 8:21 PM
LGoto removed Sbailey as the assignee of this task.Sep 12 2019, 8:33 PM
LGoto added a subscriber: Sbailey.
ABorbaWMF added a subscriber: ABorbaWMF.

I am still seeing a log out on the iOS device following a log out on desktop on 6.5.0 (1700)

Mhurd added a comment.Dec 3 2019, 10:17 PM

@ABorbaWMF Interesting!

I just re-tested the following:

  • login on sim app and then sim safari then logout sim safari
  • login on sim app and then desktop safari then logout desktop safari
  • login on desktop safari then on sim app logout desktop safari
  • login on device app then desktop safari then logout desktop safari
  • login on desktop safari then device app then logout desktop safari

None of these caused the app to logout anymore...

Is there a chance you were testing with an older build? 🤔

@Mhurd I was able to do it again on 6.5.0 (1700)

I am logging in first on the app and then desktop. Also, I am using a 2FA account.

Mhurd added a comment.Dec 9 2019, 8:00 PM

Also, I am using a 2FA account.

@ABorbaWMF

Could you re-test w/o 2FA to confirm the fix for this ticket's repro steps? (a separate 2FA patch / ticket will likely be needed, but it would be good to confirm the fix we have since it affects more users)

Yes it appears to be working on a regular login without 2FA

QutieBot closed this task as Declined.Mar 24 2020, 8:38 PM
QutieBot changed the task status from Declined to Resolved.