Page MenuHomePhabricator

Reference numbers wrong in Firefox when following a list
Closed, ResolvedPublic5 Estimate Story Points

Description

This is likely a bug in Firefox, but I'm reporting it here because it affects VE, and I can't find the root cause which would be necessary for a proper upstream bug report.

When editing an article where an ordinary list (e.g. list of external links) is followed by the list of references, the reference numbers are off by the count of the list before it. E.g. https://de.wikipedia.org/wiki/Vier_Vieren?veaction=edit has 2 external links, the references start with 3. Removing that list makes the references start with 11 instead (there is another list with 10 elements in the article).

I can only reproduce with Firefox, not with other browsers.

Details

Related Gerrit Patches:
mediawiki/extensions/Cite : masterFix broken reference list numbering in Firefox

Event Timeline

Schnark created this task.Jul 30 2019, 7:30 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJul 30 2019, 7:30 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I was able to reduce it to a minimal example, and reported this upstream as https://bugzilla.mozilla.org/show_bug.cgi?id=1569886.

matmarex added a project: Upstream.
matmarex added a subscriber: matmarex.

I can reproduce. Fascinating.

Screenshots for reference:

Firefox: (incorrect)


Opera: (correct)

If we needed to work around this, it seems that counter-reset: mw-ref-linkback works correctly when applied to ol.mw-references li:first-child instead of ol.mw-references. But presumably the same issue applies to other counters, and MediaWiki uses this in a bunch of places, so I'd rather see if a Firefox fix is coming soon first.

After reading https://drafts.csswg.org/css-lists-3/#list-item-counter: This might actually be the expected behavior (but I'm not going to encourage Firefox devs by making that comment on Bugzilla), and the correct workaround is counter-reset: mw-ref-linkback list-item.

And now I found https://bugzilla.mozilla.org/show_bug.cgi?id=1545746, which already is closed as invalid.

Pols12 added a subscriber: Pols12.Nov 22 2019, 10:30 PM

Change 555905 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Cite@master] Fix broken reference list numbering in Firefox

https://gerrit.wikimedia.org/r/555905

Change 555905 merged by jenkins-bot:
[mediawiki/extensions/Cite@master] Fix broken reference list numbering in Firefox

https://gerrit.wikimedia.org/r/555905

awight set the point value for this task to 8.Dec 19 2019, 10:44 AM
awight added a subscriber: awight.

Assigning random story points, please revise as needed.

awight changed the point value for this task from 8 to 5.Dec 19 2019, 10:45 AM
Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Dec 20 2019, 1:38 PM
WMDE-Fisch closed this task as Resolved.Tue, Jan 7, 12:30 PM
WMDE-Fisch moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2019-12-11 board.
WMDE-Fisch added a subscriber: WMDE-Fisch.

This seems to be fixed and deployed. I just confirmed using FF and the example link above.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptTue, Jan 7, 12:30 PM