Page MenuHomePhabricator

OSM maps in infoboxes on English wikipedia show wrong spelling "San Huan" of "San Juan"
Closed, ResolvedPublicBUG REPORT

Description

San Juan is the capital of Puerto Rico. Infoboxes of places / articles all over San Juan are displaying OSM (Open Street Maps) with the wrong spelling of San Juan. It is shown as San Huan. This may look like vandalism but I guess it's the map that is in the wikidata item, which is added view a BOT and seems to be San Juan spelling in a different language, maybe Dutch.

Steps to Reproduce:
The dynamically generated maps in the infoboxes of places in San Juan, Puerto Rico are displaying "San Juan" with a misspelling. It may be spelled S-A-N H-U-A-N in some languages but it is the wrong spelling in English wikipedia. See La Fortaleza page, and other places located in San Juan, Puerto Rico.

Actual Results:
Map in infobox displays capital city spelled San Huan.

Expected Results:
Map in infobox should display capital city San Juan.

Event Timeline

Level_C created this task.Jul 31 2019, 11:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 31 2019, 11:26 PM
Level_C renamed this task from OSM language auto filling infobox on English wikipedia with wrong spelling of capital city, San Juan to OSM dynamically generated maps in the infobox on English wikipedia with wrong spelling of capital city, San Juan .Jul 31 2019, 11:28 PM
Level_C updated the task description. (Show Details)

Please provide a link where to see a problem - thanks!

Screenshot from https://en.wikipedia.org/wiki/San_Juan,_Puerto_Rico which shows the correct spelling:

Aklapper changed the task status from Open to Stalled.Jul 31 2019, 11:33 PM
Level_C added a comment.EditedAug 1 2019, 3:33 AM

https://en.wikipedia.org/wiki/Puerto_Rico_Convention_Center is one where the misspelling is evident on the infobox map without having to click on it. On this one the misspelling is seen after clicking on the map within the infobox https://en.wikipedia.org/wiki/La_Fortaleza and here too: https://en.wikipedia.org/wiki/Puerto_Rico_National_Guard_Museum
Thanks!

Thanks; confirming. (I wonder if this might be an old vandalized revision.)

Aklapper renamed this task from OSM dynamically generated maps in the infobox on English wikipedia with wrong spelling of capital city, San Juan to OSM maps in infoboxes on English wikipedia show wrong spelling "San Huan" of "San Juan" .Aug 1 2019, 8:21 AM
Aklapper changed the task status from Stalled to Open.
Pikne edited projects, added Maps (Kartotherian); removed Maps (Kartographer).
Pikne added a subscriber: Pikne.

That is yet another case where Wikimedia's language picker fails to "latinize" the name. In absence of "name:en" key it could pick the value of the main "name" key from data attached to San Juan label node, but instead it picks "name:sr-Latn" due to "Latn" suffix.

As of today's review of articles with these maps, it's fixed. San Juan is correctly spelled on en.wp . I guess it's been fixed.

Pikne closed this task as Resolved.Aug 6 2019, 6:56 PM
Pikne claimed this task.

As of today's review of articles with these maps, it's fixed. San Juan is correctly spelled on en.wp . I guess it's been fixed.

Yes, two days ago someone added "name:en" tag to label node mentioned above. This does as a workaround for English label for this particular place. I suppose we can close this ticket as there are other open tickets covering the underlying language picker issue.

Pikne removed Pikne as the assignee of this task.Aug 6 2019, 6:56 PM