Page MenuHomePhabricator

labpuppetmaster1001: puppet catalog error related to canary_host
Closed, ResolvedPublic

Description

I detected this puppet issue in labpuppetmaster1001.wikimedia.org today:

aborrero@labpuppetmaster1001:~$ sudo puppet agent -tv
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Function lookup() did not find a value for the name 'profile::puppetmaster::frontend::canary_hosts' at /etc/puppet/modules/profile/manifests/puppetmaster/frontend.pp:3 on node labpuppetmaster1001.wikimedia.org
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

It seems like missing hiera config.

Event Timeline

aborrero created this task.Aug 1 2019, 11:44 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 1 2019, 11:44 AM

Change 527085 had a related patch set uploaded (by Jbond; owner: John Bond):
[operations/puppet@production] labpuppetmaster: add missing hiera key

https://gerrit.wikimedia.org/r/527085

Change 527085 merged by Jbond:
[operations/puppet@production] labpuppetmaster: add missing hiera key

https://gerrit.wikimedia.org/r/527085

jbond claimed this task.Aug 1 2019, 11:58 AM
jbond closed this task as Resolved.Aug 1 2019, 12:00 PM

Sorry for the interuption, this issues ws caused by https://gerrit.wikimedia.org/r/c/operations/puppet/+/527064 when i removed the config entry at the common level. I have now added a default of 0 canary_hosts in labs.yaml and comon/profile/puppetmaster/frontend.yaml. Please reopen if you still see issues