Page MenuHomePhabricator

Statements with unsupported properties are displayed weirdly on edit
Closed, ResolvedPublicBUG REPORT

Description

We have this:

Go to a page with data for a property with an unsupported data type
https://commons.wikimedia.beta.wmflabs.org/wiki/File:Test-1392396997.167464.png

Click 'edit' on the unsupported property ('coordinate location' in the example above)

Display is kinda screwed up (though everything still actually works)

Screenshots (if possible):

Acceptance Criteria:

  • display is the same as it is when you're editing a supported property, except faded-out a bit

During development, please test the following:

  • Test this feature while logged in AND logged out
  • Test this feature on at least one mobile browser

Event Timeline

Cparle created this task.Aug 2 2019, 5:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 2 2019, 5:01 PM

An example file on real Commons, with a monolingual text qualifier: https://commons.wikimedia.org/wiki/File:CSD_Berlin_2019_-_Lucas_Werkmeister_-_33_%E2%80%93_Pride_Is_A_Protest.jpg. (I’m sorry.)

Suggested additional acceptance criterion: the page shouldn’t ask me if I’m sure I want to leave when I close the tab without actually having started any editing.

Ramsey-WMF triaged this task as Normal priority.Aug 2 2019, 8:16 PM
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.

Suggested additional acceptance criterion: the page shouldn’t ask me if I’m sure I want to leave when I close the tab without actually having started any editing.

@LucasWerkmeister This is how it's supposed to work already, it's just that this particular bug puts the statement panel into edit mode automatically for some reason. We have a check in place to see if an actual edit has been made even if a panel is in edit mode, but the current handling of not-yet-supported input types seems to conflict with that somehow. I'm sure Cormac will figure it out :)

Restricted Application added a project: Multimedia. · View Herald TranscriptAug 10 2019, 11:54 PM
matthiasmullie closed this task as Resolved.Aug 26 2019, 2:54 PM
matthiasmullie claimed this task.
matthiasmullie added a subscriber: matthiasmullie.

Some of last week's refactors probably solved this.
Closing since I can no longer reproduce this, but if anyone else still sees this, please reopen!

It’s mostly working well now, but it’s a bit odd that the whole StatementWidget is grayed out even though the supported parts are still functional (mark/unmark as prominent, edit qualifiers, remove).

It's greyed out because that specific datatype has no proper support yet (e.g. can't edit the coordinate)
It's something we want to do soon, though: T224060