Page MenuHomePhabricator

It is not possible to deactivate Structured Discussions using the Beta feature on some wikis
Closed, ResolvedPublic

Description

It has been reported by some users from various wikis (here, here, maybe there) where SD are enabled as a Beta feature.

Event Timeline

Restricted Application added a subscriber: Cosine02. · View Herald TranscriptMon, Aug 5, 10:21 AM

The issue is confirmed on testwiki, arwiki, and cawiki. Even 'Restore all default settings' does not disable Structured discussion (the checkbox is displayed unchecked in Beta features).

SBisson claimed this task.Tue, Aug 6, 1:34 PM
SBisson triaged this task as High priority.
SBisson edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
SBisson moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.

Change 528470 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Flow@master] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528470

Change 528470 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528470

Change 528582 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.17] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528582

Change 528583 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.16] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528583

Change 528583 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.16] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528583

Change 528582 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.17] Always allow archive board creation when disabling Flow beta feature

https://gerrit.wikimedia.org/r/528582

Mentioned in SAL (#wikimedia-operations) [2019-08-06T23:49:22Z] <catrope@deploy1001> Synchronized php-1.34.0-wmf.16/extensions/Flow/includes/Import/OptInController.php: Unbreak disabling of Flow beta feature (T229795) (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2019-08-06T23:50:17Z] <catrope@deploy1001> Synchronized php-1.34.0-wmf.17/extensions/Flow/includes/Import/OptInController.php: Unbreak disabling of Flow beta feature (T229795) (duration: 00m 55s)

Etonkovidova closed this task as Resolved.Wed, Aug 7, 11:23 PM
Etonkovidova added a subscriber: Trizek.

Checked after deployment on wmf.17 and wmf.16 - seems to be working fine
@Trizek - some users who attempted to disable Structured Discussion beta features before the fix may have the checkbox for the option unchecked. To disable it now they may need to check it again/save, and then uncheck/save to disable it.

Trizek-WMF removed a subscriber: Trizek.Thu, Aug 8, 10:53 AM