Page MenuHomePhabricator

Instrument Edit Cards v3
Closed, ResolvedPublic

Description

Overview

We instrumented context items and their related workflows in T221252 and T222396.

This task is about instrumenting the new functionality we are introducing with Edit Cards v3.

Additional instrumentation

  • We would like to log an event when a contributor types text into the "Text" field within "Wikipedia" or "External site" panel/tab.

"Done"

  • The changes listed in the "Additional instrumentation" section above have been instrumented

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterMWLinkAnnotationInspector: track edits to the label field

Event Timeline

ppelberg created this task.Aug 5 2019, 3:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2019, 3:54 PM
ppelberg updated the task description. (Show Details)
ppelberg assigned this task to Esanders.Aug 5 2019, 8:50 PM
ppelberg added a subscriber: nshahquinn-wmf.
ppelberg updated the task description. (Show Details)Aug 12 2019, 4:27 PM

Task description update
Updating the "Additional instrumentation" section to include what needs to happen before this task will be ready to be worked on

@Esanders, a couple of questions:

  1. Beyond what's listed below, can you think of any changes we made edit cards v3 that are relevant to instrumentation? E.g. Did we introduce or take away any actions? Did we repurpose some UI in a way that the event it fires no longer corresponds with its actual effect?
    • Edit card:
      • REMOVED link label edit pencil
      • CHANGED to a single edit pencil for editing a link's label and target
    • Link dialog:
      • ADDED a "Label" (soon to be "Text") field
  1. Considering we have moved to a single edit pencil on the edit card in v3, what event will fire when that edit pencil is tapped?
    • In v2, it looks like we fire two different events depending on which edit pencil is tapped:
ActionEvent
[internal link] Tap the link "label" edit pencilfeature: link/internal action: context-label
[internal link] Tap the link target edit pencilfeature: link action: window-open-from-context

cc @DLynch @Neil_P._Quinn_WMF @MNeisler

On mobile we removed the link label edit pencil, so the only event that will fire is the link target one. Note that on desktop things currently remain unchanged, so the old buttons and events are required.

As we log if the user was on desktop/mobile we can distinguish between the edit-pencil-for-link-target, and edit-pencil-for-link-target-or-label use cases if we wanted to.

ppelberg added a comment.EditedAug 27 2019, 6:25 PM

On mobile we removed the link label edit pencil, so the only event that will fire is the link target one. Note that on desktop things currently remain unchanged, so the old buttons and events are required.
As we log if the user was on desktop/mobile we can distinguish between the edit-pencil-for-link-target, and edit-pencil-for-link-target-or-label use cases if we wanted to.

Thanks, Ed. In our conversation just now, we confirmed: in the version of edit cards we are deploying today, 27 August, we will be able to detect taps on the single edit pencil on mobile edit cards and differentiate those taps from those on desktop.

Our remaining open questions are:

  • 1) What tracking is live in Edit Cards v3?
  • 2) What functionality changes did we make in v3 that will require additional tracking beyond what has been implemented in v2? [1] Top of mind is the addition of the "Text" field within the link dialog. See this screenshot:
New "text" field in Edit Cards v3

  1. v2 Tracking: See this ticket for a list of what tracking we implemented in Edit Cards v2: T227933

Copying over @DLynch's responses from chat

Our remaining open questions are:

  • 1) What tracking is live in Edit Cards v3?

Everything that was live for previous versions also applies to v3.

  • 2) What functionality changes did we make in v3 that will require additional tracking beyond what has been implemented in v2? [1] Top of mind is the addition of the "Text" field within the link dialog.

v3 added the link-label editing. You presumably might want to record when people interact with said field. (Ideally with a suite of detection for "used regular surface editing instead", but that's challenging to work out.)

Updating task description to include the "Additional instrumentation" [1] we would like to implement as a result of the changes we made in Edit Cards v3. See this task: T229841.


  1. Additional instrumentation: We would like to log an event when a contributor types text into the "Text" field within "Wikipedia" or "External site" panel/tab.
ppelberg updated the task description. (Show Details)Aug 29 2019, 12:51 AM
ppelberg removed Esanders as the assignee of this task.Aug 29 2019, 12:54 AM
ppelberg added a subscriber: Esanders.

Change 534167 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] MWLinkAnnotationInspector: track edits to the label field

https://gerrit.wikimedia.org/r/534167

DLynch claimed this task.Sep 3 2019, 2:21 PM

Change 534167 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] MWLinkAnnotationInspector: track edits to the label field

https://gerrit.wikimedia.org/r/534167

ppelberg closed this task as Resolved.Sep 9 2019, 2:58 PM

QA will happen in this task: T230367