Page MenuHomePhabricator

500: invalid_request_parameters for summary
Closed, ResolvedPublic

Description

Since MCS deploymnt on 08-01 there's quite a lot of 500: invalid_request_parameters logs trying to fetch summary from MCS.

Sample MCS log message:

[2019-08-05T15:29:24.083Z] ERROR: mobileapps/79 on scb1002: 500: invalid_request_parameters (message="500: invalid_request_parameters", status=500, type=invalid_request_parameters, detail="500: invalid_request_parameters", request_id=cd668950-b795-11e9-bab3-0bbfa50eb22e, levelPath=error/500)
    stack: HTTPError: 500: invalid_request_parameters
        at Object.mUtil.createDocument (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/src/lib/mobile-util.js:261:25)
        at Object.createDocumentFromLeadSection (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/src/lib/sections/parsoidSections.js:126:18)
        at buildExtracts (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/src/lib/summary.js:105:32)
        at Object.buildSummary (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/src/lib/summary.js:127:12)
        at BBPromise.join (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/src/routes/page/summary.js:31:24)
        at tryCatcher (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/util.js:16:23)
        at Holder$3._callFunction (eval at generateHolderClass (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/join.js:1:0), <anonymous>:14:44)
        at Holder$3.checkFulfillment (eval at generateHolderClass (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/join.js:1:0), <anonymous>:29:30)
        at Promise.eval (eval at thenCallback (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/join.js:1:0), <anonymous>:6:20)
        at Promise._settlePromise (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/promise.js:571:21)
        at Promise._settlePromise0 (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/promise.js:619:10)
        at Promise._settlePromises (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/promise.js:699:18)
        at _drainQueueStep (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/async.js:138:12)
        at _drainQueue (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/async.js:131:9)
        at Async._drainQueues (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/async.js:147:5)
        at Immediate.Async.drainQueues (/srv/deployment/mobileapps/deploy-cache/revs/250f7117a30b5f716653907e3557407fca57f416/node_modules/bluebird/js/release/async.js:17:14)
        at runCallback (timers.js:672:20)
        at tryOnImmediate (timers.js:645:5)
        at processImmediate [as _immediateCallback] (timers.js:617:5)
    --
    request: {
      "url": "/pt.wikipedia.org/v1/page/summary/Temporada_da_United_SportsCar_Championship_de_2017",
      "headers": {
        "x-request-id": "cd668950-b795-11e9-bab3-0bbfa50eb22e",
        "content-length": "0"
      },
      "method": "GET",
      "params": {
        "0": "/pt.wikipedia.org/v1/page/summary/Temporada_da_United_SportsCar_Championship_de_2017"
      },
      "query": {},
      "remoteAddress": "10.64.16.117",
      "remotePort": 58200
    }

Event Timeline

Pchelolo created this task.Aug 5 2019, 4:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2019, 4:26 PM
Mholloway claimed this task.Aug 5 2019, 4:54 PM
Mholloway added a subscriber: Mholloway.

Blah. Clearly I need to figure out a single Kibana query that shows all mobileapps errors. I'll fix this after lunch.

Clearly I need to figure out a single Kibana query that shows all mobileapps errors.

For that I have filed T229835. This error doesn't show for MCS in logstash at all, only for RESTBase. This makes it difficult to catch regressions on MCS deploys, since RESTBase logstash board is an accumulation of a lot of different things. I think we need to fix T229835 and create a dedicated MCS dashboard (more like make the current one more useful) so that you can catch things like this yourself. I think I've filed >5 regression tickets over the last week and all of those would've been clearly visible on MCS dashboard if it was operating correctly.

Mholloway triaged this task as High priority.Aug 5 2019, 6:07 PM

Change 528208 had a related patch set uploaded (by Mholloway; owner: Michael Holloway):
[mediawiki/services/mobileapps@master] Fix new createDocument param type check

https://gerrit.wikimedia.org/r/528208

Change 528208 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Fix new createDocument param type check

https://gerrit.wikimedia.org/r/528208

Mholloway closed this task as Resolved.Aug 5 2019, 8:11 PM